Polaris Slingshot Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Everything worked just fine and one day the screen just went dark and nothing worked.
After checking and finding no blown fuses I assumed I would have to take it back to the
dealers for help but the next day when I started it everything started to work just fine.
Now today when I was backing out of the garage I noticed the backup camera wasn't working
and the screen was completely dark. But the funny thing is the radio is on and playing one
of the local stations. I have no volume control, no mute, no nothing except that station playing.

I will take it to the local dealer tomorrow but I get the feeling this system is toast. Has anyone else
has similar issues?
 

·
ALPHA - Home of the V8 Slingshot
Joined
·
3,162 Posts
I would take the four screws out of the face plate cover. Lift off the face plate cover and the face plate just lifts out and there are two plugs on the back side of it. Make sure those plugs are pushed in all the way. The plugs and slots are labeled ABCD
 

·
Registered
Joined
·
1,499 Posts
I would take the four screws out of the face plate cover. Lift off the face plate cover and the face plate just lifts out and there are two plugs on the back side of it. Make sure those plugs are pushed in all the way. The plugs and slots are labeled ABCD
Yes I took off one time you have two connection behind
 

·
The Pack
Joined
·
5,165 Posts
I'm sure you already tried it, but have you tried cutting it all off and then turn you key on but don't crank it. It powers up the infotainment system. Should say "loading." If that doesn't work unplug your negative battery terminal for a bit then plug it back in. It will reset all your electronics.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
I'm sure you already tried it, but have you tried cutting it all off and then turn you key on but don't crank it. It powers up the infotainment system. Should say "loading." If that doesn't work unplug your negative battery terminal for a bit then plug it back in. It will reset all your electronics.
Ok, off to the garage to try to battery cable trick I hadn't thought of that .
Thanks!
 

·
Premium Member
Joined
·
1,418 Posts
Hold down the mute button. The screen will change
Then uses the volume up button to make the screen brighter. Then turn off the auto adjust.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
Hold down the mute button. The screen will change
Then uses the volume up button to make the screen brighter. Then turn off the auto adjust.
Trust me I have tried holding the mute button down and nothing happens. Also removed negative battery cable and re installed but nothing changed. Tired of messing with it and taking to the dealer tomorrow as it's only about 5 miles away.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Just got my Slingshot back from the dealer after they installed a brand new infotainment system.
The selling dealer kept telling it would be something simple but I didn't believe it since the system
had power but the screen was dark. They couldn't offer any reason and really didn't even care to voice an
opinion on what was wrong. Guess I was lucky that I only had to leave it 48 hours to be fixed.

I think people might be wise to explore other options instead of the high priced factory unit.
 
1 - 12 of 12 Posts
Top