Polaris Slingshot Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
has anyone experienced this problem.driving along its fine and acceleration is fine.what i notice is that
when im slowing down that the RPM's drop really low and engine shuts off.i could start i right away and
continue with no issues.its only when slowing down or in idle.any help or suggestions would be appreciated.
thank you
 

·
Registered
Joined
·
4,448 Posts
has anyone experienced this problem.driving along its fine and acceleration is fine.what i notice is that
when im slowing down that the RPM's drop really low and engine shuts off.i could start i right away and
continue with no issues.its only when slowing down or in idle.any help or suggestions would be appreciated.
thank you
Try running some 'Sea Foam' in you next tank of gas! Can't hurt....some of the guys are running it once every month or two.
 

·
Registered
Joined
·
4,763 Posts
Walmart sells their equivalent to Sea Foam under the name Super Tech. Both cans seem to read the same as far as uses and it's a couple dollars cheaper.
I was experiencing some bogging under hard acceleration when I hit 4000 rpm and was afraid I might need to replace the in-tank gas pump and filter. Polaris wants several hundred Dollars for the fuel pump/filter/fuel level assembly. I tried both brands over the course of a few weeks, using one can per gas fill-up and than adding another can after a couple tanks and they both seemed to perform the same. The bogging cleared up and I now add a can every month to month and a half and haven't experienced any bogging since.
If you think you may be having problems with your fuel pump/filter/fuel level assembly, check this thread for info on replacing just the fuel pump at significant savings - https://www.slingshotforums.com/threads/fuel-pump.177351, Post # 1.
 

·
Registered
Joined
·
1,093 Posts
Without any info on your model year and history I would say that you could have your dealer reflash your ECU with the latest update if it is not current. This was/is a common issue with the early models. You can also get a custom tune from MEFI Bob or ZZPerformance that will improve it from stock.
 

·
Registered
Joined
·
7 Posts
has anyone experienced this problem.driving along its fine and acceleration is fine.what i notice is that
when im slowing down that the RPM's drop really low and engine shuts off.i could start i right away and
continue with no issues.its only when slowing down or in idle.any help or suggestions would be appreciated.
thank you
On my 2018 I've noticed that when I rev the engine while at a stop light and hte RPM's come down it sounds like it wants to but it catches it self before the RPM's get too low. I wonder if fuel rails would help that? Steve
 
1 - 5 of 5 Posts
Top