Polaris Slingshot Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2,256 Posts
I changed the oil in my procharger today and was shocked to see large metal pieces on the magnet and the oil was silver. I am saying the bearing has gone or something like that. On startup, there is a faint rattling in the housing.
That's one of those "Oh crap :(" moments. The silver is most likely aluminum. The bearing may have spun in the housing.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #6
Received my procharger back today along with a phone call. They stated that they have changed the design as they were getting numerous units back with the same issues mine did. I hope this design change has taken care of the issue,
 

·
Registered
Joined
·
38 Posts
I’m curious as to the serial no. on your CS-1 ProCharger? How many miles on it at the time of your oil change? I’ve go the same set up and my first oil change (at 500 miles) on the charger had nothing like that. The oil looked like metallic paint (aluminum) and there wasn’t much on the plug.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #9 (Edited)
I’m curious as to the serial no. on your CS-1 ProCharger? How many miles on it at the time of your oil change? I’ve go the same set up and my first oil change (at 500 miles) on the charger had nothing like that. The oil looked like metallic paint (aluminum) and there wasn’t much on the plug.
95025 is my number. First 500 mile oil change was clear clean oil. I then did another at 3000 miles,(clear) my third oil change was at 7450 miles on the procharger, and that's when I noticed the flakes and oil that was bad.
 

·
Registered
Joined
·
38 Posts
97E90530-915E-4BD4-8FFF-18C58B10564A.jpeg
95025 is my number. First 500 mile oil change was clear clean oil. I then did another at 3000 miles,(clear) my third oil change was at 7450 miles on the procharger, and that's when I noticed the flakes and oil that was bad.
Mine is only three behind yours at 95028!! I’m thinking I might be a little proactive and call them...especially as I don’t put a ton of miles on mine.
 

·
Registered
Joined
·
38 Posts
Madsheldon...FYI...Chris at CBM has a new calibration that takes care of the throttle follower decay (RPM hang) and cruise control issue. I own the MEFIPRO software and cables, reflashed tonight and will test it this weekend hopefully.
 

·
Registered
Joined
·
38 Posts
So I talked to ProCharger yesterday and they claim they have had minimal failures with the CS-1 units and that there have been no running changes to it...hmm.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #13
Madsheldon...FYI...Chris at CBM has a new calibration that takes care of the throttle follower decay (RPM hang) and cruise control issue. I own the MEFIPRO software and cables, reflashed tonight and will test it this weekend hopefully.
Did the new software help with throttle issues?
 

·
Registered
Joined
·
126 Posts
Discussion Starter #14
So I talked to ProCharger yesterday and they claim they have had minimal failures with the CS-1 units and that there have been no running changes to it...hmm.
I am not surprised, they would not want to admit an issue.
 

·
Registered
Joined
·
38 Posts
I am not surprised, they would not want to admit an issue.
Yes indeed on ProCharger’s response. However I did flash my ECU and although there has only been a couple times the RPM’s hung...it’s 95% better than it was and recommend it.
 

·
Registered
Joined
·
38 Posts
Yes indeed on ProCharger’s response. However I did flash my ECU and although there has only been a couple times the RPM’s hung...it’s 95% better than it was and recommend it.
Also...I don’t have many miles on it since the flash (100 to 150 miles) and it seems to be better as more miles get put on it.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #18
Well my Procharger has flakes in it again. I'm not happy. I change the oil in it every 2500 miles religiously. I know that has nothing to do with it, but this just pisses me off. It will now be an expensive bookend as I don't need to be stranded on the side of the road. As it has been close to 2 years since the first rebuild, I'm sure it is not covered under warranty anymore.
 
1 - 18 of 18 Posts
Top