Polaris Slingshot Forum banner

21 - 40 of 40 Posts

·
Registered
Joined
·
12 Posts
.. Mike I got this in a email alert that I had a new post from you on the forum but it never showed up on the forum maybe it will later.
Hey Don .. Okay .. I had to leave early for a medical procedure and I left instructions for some one to call you ... I just figured I'd give you the results of our efforts to this point .... We basically flashed your trans control module and went through the reteach process .. I got special...

No no one called but even if it was done I was going to wait till tomorrow to come get it. Rained hard here most of the afternoon. Don
Weird .. says it waiting on Moderator approval ?? Well ... wish I could say it was ready .... I'll reach out to you tomorrow as soon as I've had a chance to get to the office and touch base with Techline ... Shoot me an IM and This won't happen again ....
 

·
Registered
Joined
·
4,838 Posts
.. Mike I got this in a email alert that I had a new post from you on the forum but it never showed up on the forum maybe it will later.
Hey Don .. Okay .. I had to leave early for a medical procedure and I left instructions for some one to call you ... I just figured I'd give you the results of our efforts to this point .... We basically flashed your trans control module and went through the reteach process .. I got special...

No no one called but even if it was done I was going to wait till tomorrow to come get it. Rained hard here most of the afternoon. Don
Don it sounds like they have things going in the right direction. Ej
 

·
Registered
Joined
·
15 Posts
Discussion Starter #23
Weird .. says it waiting on Moderator approval ?? Well ... wish I could say it was ready .... I'll reach out to you tomorrow as soon as I've had a chance to get to the office and touch base with Techline ... Shoot me an IM and This won't happen again ....

No problem Mike I am sure the dealership and Polaris will make it right I just might take sometime. Talk to you tomorrow.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #24
Hey Don .. Okay .. I had to leave early for a medical procedure and I left instructions for some one to call you ... I just figured I'd give you the results of our efforts to this point .... We basically flashed your trans control module and went through the reteach process .. I got special directions from Techline and we performed as instructed ... Now your vehicle does have a crisper shift function but the issue persists ..... I was able to pinpoint the exact time/situation that would cause it ... I can now reproduce it almost at will ... That in affect is good ... I will be able to tell when it's corrected ... I know engineering is working on this and they put there best Tech on it ... We worked together to diagnose and repair the Challenger misfire issue ( See Thread Indian Forum ) He's very Good and motivated ... Having said that ... It's a very tiny fraction of Slingshot's that have incurred this issue .. Less than a half dozen in the country ... It doesn't make it any less aggravating but I don't want anyone to think it's a wide spread issue ... It isn't .. Just Sayin ... I've updated your case with all the results from todays procedures and results complete with digital service reports and some questions that I have to help them with the corrections nesc to get you back to riding ... I'm on it .... My gut is telling me this is going to be a software fix .... We'll see ... as always I'll keep you updated every step of the way ..
My question when it comes to software is why are only 6 having this problem unless they gave them different software the day they installed the software when they were built. I wonder if they checked if all were built at the same time. If so it could be a defective chip. They had to replace a chip in my Jeep Wrangler as it was refusing to upshift randomly. I believe that you would see a sensor that was providing bad data but maybe not the chip failing. Interesting is that Garber couldn't fix the problem with the Jeep till I found the info on the chip on the Jeep forum which have fixed a couple others Jeeps. They still didn't want to change it till I informed the right person that if this caused a wreck they would be responsible. They changed it and it has been working for years. Btw this chip went bad as the problem started after I had the Jeep for a while. The thing you guys have going for you is you guys have the technician experence backed by Techline and Jeep didn't.
 

·
Registered
Joined
·
3 Posts
So ... basically it's pretty simple ... From a stop you gently accelerate to approx 15 miles per hour then come to a complete stop ... You repeat this 6 times to complete the PDI process ... After the 6th stop you need to engage the parking brake and turn the vehicle completely off for a few minutes while the Trans module hard writes the data to it's memory. Now having said that these trans modules are very similar to the new gen ECU that Polaris is using in the INDIAN motorcycles ... it's a learning AI ..... It will continue to learn how you drive and your shifting will get better and better the more miles you put on it .. Hope this helps ..

Thank you very much! I was hoping it would be constantly evolving. I'm planning on a few hundred miles this weekend to get it to the break-in so I should be good after that. I'm expect I'll be a lot braver in driving the SS later into the season up here in NH, but I'd love to get the kinks out before I park it for a month or three....
 

·
Premium Member
2020 R SlingShot
Joined
·
92 Posts
Let me know if you get the clunking improved.
I have a 2020R Std and have clunking. I know exactly where mine comes from and recommend you check same. I posted a video here a few months back.
At about 770 miles, I started to notice a clunk when driving slow and I would take my foot off the gas.
Upon investigation, I discovered it was coming from the driveshaft spline entering the angle-drive. For the record, I took it to Polaris and they agree it is excessive and documented it. I was told to watch it closely.

If you have an automatic, I would place it in Reverse with the park-brake off. Get out of the vehicle and get behind it and try to roll the rear wheel back and forth. If it is the spline, you should be able to repeat the "clunk" sound.

I actually crawled under mine and tic marked the shift entering the drive at both ends of the clunk. I also videod it. I periodically check to see if the clunk has gone beyond the tic marks.

You issue might be different but you might as well rule this out.
 

·
Registered
Joined
·
12 Posts
I have a 2020R Std and have clunking. I know exactly where mine comes from and recommend you check same. I posted a video here a few months back.
At about 770 miles, I started to notice a clunk when driving slow and I would take my foot off the gas.
Upon investigation, I discovered it was coming from the driveshaft spline entering the angle-drive. For the record, I took it to Polaris and they agree it is excessive and documented it. I was told to watch it closely.

If you have an automatic, I would place it in Reverse with the park-brake off. Get out of the vehicle and get behind it and try to roll the rear wheel back and forth. If it is the spline, you should be able to repeat the "clunk" sound.

I actually crawled under mine and tic marked the shift entering the drive at both ends of the clunk. I also videod it. I periodically check to see if the clunk has gone beyond the tic marks.

You issue might be different but you might as well rule this out.
Thanks I will check this.
 

·
Registered
Joined
·
12 Posts
I have a 2020R Std and have clunking. I know exactly where mine comes from and recommend you check same. I posted a video here a few months back.
At about 770 miles, I started to notice a clunk when driving slow and I would take my foot off the gas.
Upon investigation, I discovered it was coming from the driveshaft spline entering the angle-drive. For the record, I took it to Polaris and they agree it is excessive and documented it. I was told to watch it closely.

If you have an automatic, I would place it in Reverse with the park-brake off. Get out of the vehicle and get behind it and try to roll the rear wheel back and forth. If it is the spline, you should be able to repeat the "clunk" sound.

I actually crawled under mine and tic marked the shift entering the drive at both ends of the clunk. I also videod it. I periodically check to see if the clunk has gone beyond the tic marks.

You issue might be different but you might as well rule this out.
Thanks I will check this.
Thanks I will check this.
I did what you said and jacked it up and maybe it had 1/8 inch play in driveline. How did yours compare to that?
 

·
Registered
Joined
·
12 Posts
I did what you said and jacked it up after checking for the clunk and it maybe had1/8 inch play in the driveline. How did yours compare with this?
 

·
Registered
Joined
·
12 Posts
My question when it comes to software is why are only 6 having this problem unless they gave them different software the day they installed the software when they were built. I wonder if they checked if all were built at the same time. If so it could be a defective chip. They had to replace a chip in my Jeep Wrangler as it was refusing to upshift randomly. I believe that you would see a sensor that was providing bad data but maybe not the chip failing. Interesting is that Garber couldn't fix the problem with the Jeep till I found the info on the chip on the Jeep forum which have fixed a couple others Jeeps. They still didn't want to change it till I informed the right person that if this caused a wreck they would be responsible. They changed it and it has been working for years. Btw this chip went bad as the problem started after I had the Jeep for a while. The thing you guys have going for you is you guys have the technician experence backed by Techline and Jeep didn't.
Hey Don .... Thanks ... We're all working hard to get resolution on this ..... I've sent numerous service reports to engineering for analysis .. Basically it's a snapshot of all the vehicles functions and readings that occurred when the event happened ..... My go to guy at Techline was in meetings all day yesterday and I'm sure some of it was about the shifting issue .... I'll try again this morning to contact him by phone and I'll keep you posted .... The case still shows as "researching" as of yesterday at 6pm .....
 

·
Premium Member
2020 R SlingShot
Joined
·
92 Posts
I did what you said and jacked it up after checking for the clunk and it maybe had1/8 inch play in the driveline. How did yours compare with this?
1/8 inch sounds pretty tame. But you can go to my video and compare.

MyClunking
This will take you to my post. Clink in the link there to see my little video and compare.
 

·
Registered
Joined
·
12 Posts

·
Registered
Joined
·
3 Posts
Don't look like anyone here has heard of this either just like my dealer and his service team. Hope Polaris has a clue Tuesday I want to be driving this new machine.
Hi I just purchased the automatic slingshot last Friday. I'm headed to thr dealership on Tuesday because of the problem with it shifting into neutral. It's an accident waiting to happen. Did they ever figure out what the problem was with yours?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #35
Yes Polaris has figured out it is a software problem and they have the fix done. They are now waiting for the DOT to approve the fix. My SS has been sitting at the dealer for a month now. Your right it is a accident waiting to happen and I filed a incident report and that I think is why the DOT has it now. I was told that maybe a week or 10 days for the DOT approval then the dealer can do the new software install. My dealer's shop foreman knows how to make it fail every time and has been in touch with Polaris engineering during this time. Yep bought my SS on a Friday afternoon and was waiting Saturday morning for the dealer to open. That was Oct 17th. Thank goodness my dealer and their shop foreman are really great and doing all they can. Don
 

·
Registered
Joined
·
3 Posts
I bought it as a rental and this would have been the first weekend that it went out. Now I'm wondering when I can start making my money back. Last time I pay cash.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #37
Well I originally thought it was going around corners and tight curves but it will do it on straight a ways also. It is up shifting and down shifting and I think it get confused and just goes to neutral. I would say don't drive it and am sure Polaris would agree. It is not a good feeling to have a big F350 on your tail and in a hurry because the 25 mph speed limit in our housing area is to slow for him and the thing goes into neutral. Curb on the right and no room to pull over. I am hoping that I will get it back by the end of the week but we know how slow these government agencies can be. My hope is being a safty issue DOT will make it a priority. BTW my family is now calling it The LemonShot. Don
 

·
Registered
Joined
·
4,838 Posts
I bought it as a rental and this would have been the first weekend that it went out. Now I'm wondering when I can start making my money back. Last time I pay cash.
I would be real careful about renting out the Slingshot 'auto' --- most of the people who will want the "Auto Tran" probably don't drive the simple sedan they have very well! Give them this machine and trouble looking your way. I have 98,000+ miles on personal Slingshot and have worked with my dealer over several years doing test rides with the earlier Slingshots and everybody wants drive it like there at 'Indy'. And yes I do drive it like I'm practicing for Indy --- 98,000+ miles I know my machine.
 

·
Registered
Joined
·
12 Posts
Yes Polaris has figured out it is a software problem and they have the fix done. They are now waiting for the DOT to approve the fix. My SS has been sitting at the dealer for a month now. Your right it is a accident waiting to happen and I filed a incident report and that I think is why the DOT has it now. I was told that maybe a week or 10 days for the DOT approval then the dealer can do the new software install. My dealer's shop foreman knows how to make it fail every time and has been in touch with Polaris engineering during this time. Yep bought my SS on a Friday afternoon and was waiting Saturday morning for the dealer to open. That was Oct 17th. Thank goodness my dealer and their shop foreman are really great and doing all they can. Don
Thanks Don .... I'm on them every day .... They just keep telling me any day now .... Very frustrating to not be able to get you back on the road .....
 

·
Registered
Joined
·
3 Posts
I would be real careful about renting out the Slingshot 'auto' --- most of the people who will want the "Auto Tran" probably don't drive the simple sedan they have very well! Give them this machine and trouble looking your way. I have 98,000+ miles on personal Slingshot and have worked with my dealer over several years doing test rides with the earlier Slingshots and everybody wants drive it like there at 'Indy'. And yes I do drive it like I'm practicing for Indy --- 98,000+ miles I know my machine.
First I have to get it back from the dealership. Polaris knew full well this machine should not have gone to market with the issues. I hope no one gets killed while waiting for this software update to be approved, What I really want is my money back.
 
21 - 40 of 40 Posts
Top