Polaris Slingshot Forum banner

21 - 35 of 35 Posts

·
Registered
Joined
·
1,470 Posts
I'm going to go out and pull the IC unit and jiggle all the wires and see if that helps but so far all I have is that blue screen.
 

·
Registered
Joined
·
1,869 Posts
Discussion Starter · #22 ·
Yea, the fact that mine started working again seems to point to a faulty connection somewhere.
 

·
Registered
Joined
·
1,869 Posts
Discussion Starter · #23 ·
Ok, fired up the SS to back out of the garage yesterday for a run, low and behold backup camera not working again. Just a blue screen. So, connections, camera or the Stereo/Screen Infotainment center? Odd that it works and doesn't work.
 

·
Registered
Joined
·
2,109 Posts
Don't rule out temperature/humidity factors on intermittent problems.
 

·
Registered
Joined
·
1,470 Posts
Any updates about the back-up camera issues? Mines still not working but I haven't had a chance to get it to the dealer or even check the wires in the back of the camera.
 

·
Registered
Joined
·
1,869 Posts
Discussion Starter · #26 ·
Dealer replaced mine during 500 mile service. All is well at this point. So even though it started working again and then quit, it appears to be the camera and not connections.
 

·
Registered
Joined
·
1,670 Posts
about 500 miles on my replacement... That's exactly 500 miles more than the original...

Looks like the replacements might be better... One can only hope. Sorry to hear yours is still not working.
 

·
Registered
Joined
·
1,470 Posts
As soon as the weather clears I'll get more concerned about getting it fixed. We are about 2 inches away from having the wettest April ever and the month is only half over. Oh well, 'stuff' happens.
 

·
Registered
Joined
·
1,670 Posts
As soon as the weather clears I'll get more concerned about getting it fixed. We are about 2 inches away from having the wettest April ever and the month is only half over. Oh well, 'stuff' happens.
With you on the wet.... Rain solid through Monday.... for now. Had a 30 minute break yesterday for a short run.

Been trying to get my house painted for three weeks now. They have had 3 good days!
 

·
Registered
Joined
·
1,869 Posts
Discussion Starter · #33 ·
Gotta luv it! My money would be expect it to fail solid soon. Let your dealer know, show him the pic, if he's a good dealer, he may just change it out.
 

·
Registered
2016 Slingshot SL 4,000 miles
Joined
·
20 Posts
My camera died 2 months ago. After 21 days in service the replaced the camera and still just a blue screen. How nice
 
21 - 35 of 35 Posts
Top