Polaris Slingshot Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
So, I had my SL towed to dealer because I almost rear ended a car when it decided to apply throttle when I didnt. I have it in for 4 issues. Black coming off of the seat, the black is literally flaking off. Check engine code, no light just the code that no one knows wat it means. Engine revs dropping to 500rpm coming to a stop and the entire machine shakes, but it never has stalled. And the rpm hanging/surging issue.

I got a call from an 800 number and it was someone from Polaris asking me more detailed info. First off, I applaud them for wanting to get the customers info first hand as things get lost in translation. The other thing I thought was interesting was, my dealer told me that Polaris has been reading this forum and knows about the issues. The dealer specifically said something about 1 unit revving on its own to 7000 Rpm's. And my dealer does not read forums. Anyway, we had a 20 minute conversation and Polaris had to call me back twice due to the call dropping. They were nice to deal with and showed a genuine concern. I only shared the info that happened with my unit.

I'll keep you all updated as the process moves forward. I don't need the unit back anytime soon because Chicago weather will suck until late March.

Good luck all and ride/drive safe! Happy holidays!!!
 

·
Registered
Joined
·
503 Posts
So, I had my SL towed to dealer because I almost rear ended a car when it decided to apply throttle when I didnt. I have it in for 4 issues. Black coming off of the seat, the black is literally flaking off. Check engine code, no light just the code that no one knows wat it means. Engine revs dropping to 500rpm coming to a stop and the entire machine shakes, but it never has stalled. And the rpm hanging/surging issue.

I got a call from an 800 number and it was someone from Polaris asking me more detailed info. First off, I applaud them for wanting to get the customers info first hand as things get lost in translation. The other thing I thought was interesting was, my dealer told me that Polaris has been reading this forum and knows about the issues. The dealer specifically said something about 1 unit revving on its own to 7000 Rpm's. And my dealer does not read forums. Anyway, we had a 20 minute conversation and Polaris had to call me back twice due to the call dropping. They were nice to deal with and showed a genuine concern. I only shared the info that happened with my unit.

I'll keep you all updated as the process moves forward. I don't need the unit back anytime soon because Chicago weather will suck until late March.

Good luck all and ride/drive safe! Happy holidays!!!
Its great to hear that you are getting personal attention to your problems. Polaris is well known for follow up on issues with units.
 

·
Registered
Joined
·
480 Posts
It's great to hear that someone from polaris is checking this site. I'm part of a big forum that has to do with one of the technologies in my field and having the manufacture listen to the consumers on that forum is a pretty huge deal.
 

·
Registered
Joined
·
1,050 Posts
So, I had my SL towed to dealer because I almost rear ended a car when it decided to apply throttle when I didnt. I have it in for 4 issues. Black coming off of the seat, the black is literally flaking off. Check engine code, no light just the code that no one knows wat it means. Engine revs dropping to 500rpm coming to a stop and the entire machine shakes, but it never has stalled. And the rpm hanging/surging issue.

I got a call from an 800 number and it was someone from Polaris asking me more detailed info. First off, I applaud them for wanting to get the customers info first hand as things get lost in translation. The other thing I thought was interesting was, my dealer told me that Polaris has been reading this forum and knows about the issues. The dealer specifically said something about 1 unit revving on its own to 7000 Rpm's. And my dealer does not read forums. Anyway, we had a 20 minute conversation and Polaris had to call me back twice due to the call dropping. They were nice to deal with and showed a genuine concern. I only shared the info that happened with my unit.

I'll keep you all updated as the process moves forward. I don't need the unit back anytime soon because Chicago weather will suck until late March.

Good luck all and ride/drive safe! Happy holidays!!!

I got the same call from Polaris yesterday since I have been calling them every other day for weeks about the same issues with the RPMs. I was told to drop the SL at the dealer. Which I will after the Holidays.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #7
I was contacted by my dealer and they told me what they did and requested that I not share the info until later. But at this point, all needs to be shared. They said polaris asked them to take some ECU readings with the clutch in and out and they sent the info but it was the same. Supposedly the switch wasn't working properly and needed adjustment.

Well, I picked up the machine last night and OMG what a difference. It idled smoother, shifted the best it had, revved quicker and the Rpm's never dropped under 700 when coming to a stop. I was so happy and couldn't wait to share the info with you all.

And then I reached about 75 miles from when I picked it up. With approx 3 restarts due to reaching destination and starting new trips. It started doing everything it was, but way worse. Started dropping revs when coming to a stop. I tried many different things trying to see if I could make it do it every time and there seemed to be no rhyme or reason. And then the rpm hang and revving up started. Before it would hang for 1-2 seconds and drop with it sometimes revving up 500-1000rpms. Now it would hang for 3-4 seconds and it revved up well above 1500rpms. Now here's the best part. I was taking it for a drive in downtown Chicago to get some pics. Anyway, I was driving down Michigan (Magnifecent Mile). It was 50 degrees, very uncommon for this time of year and the streets were crowded due to the fair weather. I was coming to a red light with no one in front of me, crosswalk was full, and I was in first gear decelerating with engine braking. Then a big surge hit. I wasn't expecting it and immediately slammed on the brakes and the clutch. It revved up to 3000 Rpm's and everyone was looking at me like I was an idiot. My heart almost jumped out of my chest. I could have easily taken out 10 people. Polaris would have had their ass handed to them in court. I'm going to call them on Monday and share this story with them. Plus I'll need to get it in the dealer again, 50 miles away and it was towed the first time.

I was hoping to get some more miles on it today with a gopro pointing at the gauges, but it rained earlier in the day and I was busier later. I will need to do this in a rural area.
 

·
Registered
Joined
·
1,289 Posts
Well some might call it "active pursuit" and slap Polaris on the back for being proactive and attentive to their clients, but obviously we are beta testing this thing and we are doing it for a lot less than the engineers would be getting paid.
Yes, I agree the issues will be fixed as quickly as Polaris wants to fix them, etc, but I still cant see how a few of these widespread problems were not noticed in all the demo rides, production qc and what not. I mean, all they had to do was drive just one of them.
Any NOOB driver would have noticed that idle and asked, "Um, is this the way its supposed to idle and decel?"
Rose colored glasses?
IDK.
Hopefully these nagging issues will be resolved by spring.
 

·
Registered
Joined
·
263 Posts
Mine stalled on me yesterday while decelerating in gear to make a left turn with oncoming traffic coming at me.I made the turn ahead of the traffic,but looked like an idiot slowing down in front of them while into the turn.
 

·
Registered
Joined
·
2,109 Posts
Mine stalled on me yesterday while decelerating in gear to make a left turn with oncoming traffic coming at me.I made the turn ahead of the traffic,but looked like an idiot slowing down in front of them while into the turn.
This is sounding more agravating all the time.

I think the idle control valve (or function) is over reacting on deceleration (engine braking) or the throttle response time of the ECU is too slow after comming to a stop. There may be an easy way to fix this if there is a hardware idle adjustment screw on the throttle body.

Any gear heads with SS willing to look at the TB and see if there is an idle adjustment screw? If so, try setting it a little higher. The ECU should bring the actual idle RPM back down to the normal 750 but the lower limit screw might prevent the ECU from over reacting when engine braking.

This won't help the 'rpm flare' thing though.
 

·
Registered
Joined
·
105 Posts
wow, I've been experiencing slight rev up when just moving in line at a traffic light as soon as pressing in the clutch , nothing with down shifting and has never stalled out , however a few times I thought it was
 

·
Registered
Joined
·
83 Posts
I am having the same problem with the revving up between changing gears,sometime as much as 1000rpm,I phoned Polaris and they said they were looking into it,and I also complained to the dealer 3 times with no results.I had this problem from day one.I am not too happy with the answers from them.I am going to phone them again on the Monday the 27th.of April I enjoy the SS but getting tired of all issues I am having.I just cant seem to get proper .I am also having the issue when shifting with ,it sounds like u-joint loose.Paul 239 673-8931
 

·
Registered
Joined
·
1,493 Posts
Paul.
Do not expect anything from them on the revving issue except a lot of verbal BS. This was explained to Polaris when the first SS was delivered back several months ago and they do nothing about it. They must reprogram the ECU in order to resolve this problem. They know it but will not admit it or do anything about it up to this point. Good luck to you.
PS. Tell them about this comment when you talk to them.
 

·
Registered
Joined
·
271 Posts
I waiting James to hear if the problem sneaks back in, I know when I get mine home, my son and I have already decided to gut the exhaust and do a CAI right of the bat, then build a new exhaust system to make room for the W/I system (water/methanol injection ) so your news is really helpful.

Doug
 

·
Registered
Joined
·
503 Posts
I waiting James to hear if the problem sneaks back in, I know when I get mine home, my son and I have already decided to gut the exhaust and do a CAI right of the bat, then build a new exhaust system to make room for the W/I system (water/methanol injection ) so your news is really helpful.

Doug
i Have over 3K mi on the new intake system and the problem never came back.
 

·
Registered
Joined
·
2,109 Posts
My stock 3-15 build SS has not had the low idle/stall or high rev problem for the most part for the first 1700 miles. Recently, once in a great while it will seem to do the rev hang thing but not much of a problem. It's usually when I do an unusual sequence of clutch and braking when coming to a stop. Need to pay more attention to what led to it.

Sooner or later I hope Polaris will have to admit that there is a problem on earlier builds. I suspect the 'fix' will not be free though. Probably to be called an 'enhancement' :)
 

·
Registered
Joined
·
271 Posts
Thats good news


Doug
 

·
Registered
Joined
·
1,149 Posts
Has anyone got a fix or resolved this? My SS is doing the, "lets stall at a red light"
 

·
Registered
Joined
·
434 Posts
my gawd, you'd think Polaris would be on this like stink on s#@.

The company needs to be reminded of Toyota's unintended acceleration problem that eventually cost them $1+BILLION settlement !!

Is it going to take a death of a rider/passenger before they fix it? The delay is beyond ridiculous at this point.
 
1 - 20 of 25 Posts
Top