Polaris Slingshot Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
Took another test drive today (with my wife -- more on that in a bit*).

Whenever I started out from a stop, there was a hot smell that we both noticed. I didn't detect anything like that on my last outing. Last time I drove it, it felt like I wasn't giving it enough gas to get started -- like it was about to sputter and stall when. This time I gave it more gas, but after getting the hot smell I backed off quite a bit... but still got that smell.

I asked the dealer about it, and it was a surprise to him. He asked if I had the e-brake on, which is the first thing I checked -- it wasn't on. And the smell was only in 1st gear... by the time I got into 2nd, it was gone (whether it was fully gone or just had blown out of the driver/passenger area, I don't know).

Any thoughts?


*Talked wife into going on a test drive just to see if she'd fall in love with it. She didn't.
 

·
Registered
Joined
·
4,124 Posts
Probably just the newness burning off the exhaust and motor. :cigar:
 

·
Registered
Joined
·
1,207 Posts
Took another test drive today (with my wife -- more on that in a bit*).
Any thoughts?


*Talked wife into going on a test drive just to see if she'd fall in love with it. She didn't.
Lots of smells coming off of other cars Im constantly being freaked out by it .
Not much to be done with the wife Im afraid .
You could try taking her to a couple of gun stores
.Women can read between lines when they want to .
 

·
Vendor
Joined
·
2,216 Posts
Took another test drive today (with my wife -- more on that in a bit*).

Whenever I started out from a stop, there was a hot smell that we both noticed. I didn't detect anything like that on my last outing. Last time I drove it, it felt like I wasn't giving it enough gas to get started -- like it was about to sputter and stall when. This time I gave it more gas, but after getting the hot smell I backed off quite a bit... but still got that smell.

I asked the dealer about it, and it was a surprise to him. He asked if I had the e-brake on, which is the first thing I checked -- it wasn't on. And the smell was only in 1st gear... by the time I got into 2nd, it was gone (whether it was fully gone or just had blown out of the driver/passenger area, I don't know).

Any thoughts?


*Talked wife into going on a test drive just to see if she'd fall in love with it. She didn't.
Haha. Wasn't sure what to expect on your thread title "Hot Smell".. but.. I had the same issue. I'm at 1400 miles now.. no more weird scents.
 

·
Registered
Joined
·
111 Posts
I agree with everyone on this. Most new cars have a coating on the exhaust that burns off within the first hundred or so miles. It's supposed to make them last longer and look better but from what I'm seeing, they are looking like crap after only a short time. I'm looking forward to the Covers that are in the works from our forum members.
 

·
Registered
Joined
·
1,137 Posts
I smelled it a bit too....glad it wasn't just my imagination!
 

·
Registered
Joined
·
266 Posts
Discussion Starter #8
Thanks for the feedback, all. Good to know it's nothing to be alarmed about. I just thought it was strange that I didn't smell anything the first time out (the day of their arrival), but I smell it now (with 300+ miles on it).
 
1 - 9 of 9 Posts
Top