Polaris Slingshot Forum banner

1 - 20 of 37 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1
Has anyone else had issues with the fuel gauge out of the box? I picked up my base SS on Friday, with a full tank of gas. About 10 miles into my ride home, the fuel gauge started dropping to empty, then flashing from full to empty. 10 miles later, the fill fuel light came on, and stayed on until I got home. I stopped on the way, and called the dealership. They said they had filled it up. The next day, on my way out of the neighborhood, I stopped and topped off the gas. It only took a gallon. Same thing again. 10 miles later the gauge is flashing from full to empty and 10 miles beyond that, fill fuel light came on.

My dealer has been very helpful, and I plan to drop the SS off later this week. I am hoping it is just a loose connector. Anyone else having this issue?
 

·
Registered
Joined
·
574 Posts
Your not alone, Mine has never worked. My dealer will take care of this when the part gets here. They had to order new fuel pump assembly. I have been filling the tank every 120 miles or so and ignoring the light
 

·
Registered
Joined
·
1,281 Posts
The gauge on my polaris atv has never worked right, I hope they didn't use the same float design.
 

·
Registered
Joined
·
163 Posts
Discussion Starter #4
Your not alone, Mine has never worked. My dealer will take care of this when the part gets here. They had to order new fuel pump assembly. I have been filling the tank every 120 miles or so and ignoring the light
Thanks Thomas! I will let them know at the dealership when I drop mine off.
 

·
Registered
Joined
·
903 Posts
Has anyone else had issues with the fuel gauge out of the box? I picked up my base SS on Friday, with a full tank of gas. About 10 miles into my ride home, the fuel gauge started dropping to empty, then flashing from full to empty. 10 miles later, the fill fuel light came on, and stayed on until I got home. I stopped on the way, and called the dealership. They said they had filled it up. The next day, on my way out of the neighborhood, I stopped and topped off the gas. It only took a gallon. Same thing again. 10 miles later the gauge is flashing from full to empty and 10 miles beyond that, fill fuel light came on.
Sorry I'm late to this party, But mine did and does exactly this! If they replace the gauge cluster, I hope I don't get the ones with the bubbles!!
 

·
Registered
Joined
·
163 Posts
Discussion Starter #9
@ConnMan @larnanc Sounds like we all have the exact same issue! It's odd that it stops when completely full...
Hopefully it's an easy fix. I went by the dealer at the beginning of the week, and they were submitting a query to Polaris. Should have a fix when I go in for my 500 mile service in the next 10 days. I will keep you guys posted.
 

·
Registered
Joined
·
903 Posts
Please post the dealer fix when it happens. Unfortunately for me, mine won't see the road again until the Spring rains wash the chemicals off the roads up here. I don't anticipate the 500 mile check until April. My dealer is a trek, so I'll bring it back once to dot all the I's and..........
 

·
Registered
Joined
·
2,109 Posts
Sounds like the fuel level sender is bad. Had that happen on a few machines.

How hard is it to get to and change on the SS? I hope they would not make it a non replaceable part requiring the tank to be changed.
 

·
Registered
Joined
·
163 Posts
Discussion Starter #13
Judging by what Thomas said above, it is all part of the fuel pump assembly. I bet it is under the deck body panels where the fin is.
@ConnMan , I will keep you guys posted.
 

·
Registered
Joined
·
903 Posts
Has anyone had the fuel gauge issue fixed yet? My dealer is coming to pick up my SL in a week or so. Told them about the gauge, they said it was the first they heard of a problem like that. However, I found out of all the Slingshots they sold, (less than 10), I'm the only one that took delivery. I told them they should monitor this forum, to keep an eye on the issues. Hope they can handle the fuel gauge when they are dealing with the recall!!!
 

·
Registered
Joined
·
242 Posts
Hey there holdfast...
Mine's the same deal right from when I picked it up. Does everything you said yours does, top it off and it's fine to a certain point, then starts it all over again. dealer will repair it when I get the steering issue done. There is also another thread somewhere, that was started a long time ago. Seems like quite a few of us are experiencing it.............
 

·
Registered
Joined
·
163 Posts
Discussion Starter #17
Yep. Once it goes to the dealer next week, they should be able to take care of it with the recall issues.
 

·
Registered
Joined
·
2,741 Posts
Only 281 miles on mine... have not ridden in a month ..(seems like a year).. no problem yet???? I hope........................................
"We Shall See What We Shall See"


"Only Time Will Tell"..........................................tom
 
1 - 20 of 37 Posts
Top