Polaris Slingshot Forum banner

21 - 32 of 32 Posts

·
Registered
Joined
·
2,510 Posts
The people that are posting speeds above 125 need to post some proof. I have my doubts on any stock SS running up in the 130 range. Its hard enough to get to 135 with 8 pounds of perfectly tuned boost.
I hit speed limiter before turbo.
 

·
Registered
Joined
·
2,510 Posts
I have slightly bumped 135 but I'm telling you it's like hitting a wall. Even with ample boost
I wrung it out down hill off bridge and held max speed for at least 30 seconds (felt forever ) and it just bounced around 135, with turbo.

It could be terminal but I think it's limited
 

·
Registered
Joined
·
1,110 Posts
I would try hitting 130 a lot but seemed to always hit 100 and couldn't get no more. But a couple days ago out later in the evening no wind from route 2 to route 30 tucked down behind windshield and punched it. Had to stay in 4th but got it. It was ruff on the old girl though.
 

·
Registered
Joined
·
1,670 Posts
I would post a video but at that speed when I turn the cameras goes out be cause of the G forces.
Agree... Only needed to do it one time just to see.. Slight downhill run and the Factory speedo showed just over 125ish.. Didn't look at it for long. Take it with a grain of salt. No proof or video... Don't know how far off the speedo is from the factory. Like others it just hit a wall.. Bad aerodynamics..
 

·
Registered
Joined
·
5,881 Posts
Its really amazing how hard those last few MPH are on this thing. I have the MEFI data logger software and I promise the limiter is set to 160mph. I have always heard there is a ratio of power to speed vs drag and now I believe it. One day I will hammer mine on a long stretch and see what she can pull out of her butt. I have a video of the top of 4th and then some in 5th but I cant see the speedo in it very good. Ill look again and see if you can tell how fast it was.
 
  • Like
Reactions: rusty davis

·
Registered
Joined
·
5,881 Posts
This is my last video that I made a pull to the redline of 4th and then gained a fuzz in 5th. Its a terrible video. I just thought I would upload it and let y'all see the top of 4th gear. I just wish that it was clear and we could see it better. I didn't think about the light having this much of an effect on the video. Its uploading now and it like about 5 minutes.

 

·
Registered
Joined
·
167 Posts
My front fenders wobble at high speed - over 85 - I adjusted the front fender supports a little but afraid to go any more . Anyone else have this problem ? I have a 3/4 gap between the top of the fender where it rest on top of the lights . I had to put new rubber supports on the hood , being the old ones fell of - and my dealer says they are on back order .
Solutions ?
 
21 - 32 of 32 Posts
Top