Polaris Slingshot Forum banner

601 - 612 of 612 Posts

·
Registered
Joined
·
3 Posts
My radio reception was poor, reason broken BAWM200 antenna ( not going to discuss reasons, that is touched somewhere else). I bought a 20$ Glass mount antenna from Advance Auto and mounted it between the windshield and dash ( THERE IS ENOUGH ROOM FOR IT TO FIT PERFECTLY). Remove windshield !!!! My reception went from 0 to 100 and View attachment 15663 Pandora did not lose signal once.
 

·
Registered
Joined
·
3 Posts
Can you give me the antenna brand and stock number? Checked with Advance Auto, and showed them your post, however they had no clue!
 

·
Registered
Joined
·
8 Posts
Maybe this might be the problem with the radio reception. When I unhooked it to install the FM booster the cable has a male end with the pin, the female has the socket, well the male had no pin. It was stuck in the female socket. I think the pin Is crimped into the male end. Being loose does not help reception.
 

·
Registered
Joined
·
121 Posts
You did not indicate that the antenna had been moved. In my 16 SS SL -antenna was laying down (under the center fin). Reception was terrible and weak. Technician showed me that -if you raise the antenna-reception improves. I drilled hole in top of fin and I can now get reception from stations 50-60 miles away (in daytime). The problem, I see, is the antenna is not positioned correctly. It might not work on all SS.Good luck and hope you get your problem resolved.
 
601 - 612 of 612 Posts
Top