Polaris Slingshot Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
686 Posts
Thanks again @Slingking!! You do awesome install vids, and the review vid was really informative!!! Priceless info for noobs and even seasoned mechanics!!!
 

·
Vendor
Joined
·
5,412 Posts
Discussion Starter #4

·
Registered
Joined
·
901 Posts
I always refrain from using the horn, because of the weak sound of it. Had a Chevy pickup truck in the 90's with the same issue. I'm going for this mod, because it adds to the character of these awesome machines!! Great video's Joe! You take the intimidation factor out of the install. Perhaps you could do an investigative video about why so many of us are having problems with the turn signal mod! I hope they find the issue with it, because I truly love that look and want it back!!
 

·
Vendor
Joined
·
5,412 Posts
Discussion Starter #9
I always refrain from using the horn, because of the weak sound of it. Had a Chevy pickup truck in the 90's with the same issue. I'm going for this mod, because it adds to the character of these awesome machines!! Great video's Joe! You take the intimidation factor out of the install. Perhaps you could do an investigative video about why so many of us are having problems with the turn signal mod! I hope they find the issue with it, because I truly love that look and want it back!!
Thanks ConnMan! Sorry, I just saw this. :) I'll get back to you here in a minute.
 

·
Registered
Joined
·
658 Posts
Installed the horn today. Didn't work. Must be a bad horn because I had 12 VDC at the connectors which go on the bottom of the Flosser horn. I would think the relay is ok.
 

·
Vendor
Joined
·
5,412 Posts
Discussion Starter #11
Installed the horn today. Didn't work. Must be a bad horn because I had 12 VDC at the connectors which go on the bottom of the Flosser horn. I would think the relay is ok.
Bummer man, Let's get that taken care of. I'll PM you here in a few minutes. Sorry for the inconvenience my friend. :)
 
1 - 11 of 11 Posts
Top