Polaris Slingshot Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
1,459 Posts
Discussion Starter #1
Recent turn signal mod works great while in accessory mode however once SS is started and left or right signal is applied the mod stops working. Will work as expected with key accessory mode. So the QUESTION IS what happens to output or input of a relay when SS has engine running that is not present in accessory mode?:confused:

The following video is of the mod working
however once I start the SS and activate a turn signal the mod stops to work properly any thoughts?
 

·
Registered
Joined
·
1,459 Posts
Discussion Starter #3
Well it aint that simple partner
upload_2016-2-12_13-8-43.png
with all LEDs on and all accessories on, lights on even at high beam it works well so it not a general "current draw" or Load issue it IMHO is related to the relay and how its affected once the engine is turned on, is there any other component that is inert and waiting for the engine to start that affects the relay. Generator possibly?
 

·
Super Moderator
Joined
·
2,871 Posts
Not the alternator (takes power to make power, not actually a generator), as the engine isn't running. I'd watch the voltage swing, the power steering unit, fuel pump, etc. will drawn down the tiny battery. You might be on that hairy edge where it matters. LEDs don't draw much current relative to electric motors. The relay shouldn't act any different. What happens when the engine is running?

Love the mod, by the way. Do you have a link to it??? Or a write-up?

(Lights on high-beam don't matter in the U.S., it's just a flapper that moves out of the way.)

 

·
Registered
Joined
·
7,043 Posts
Not the alternator (takes power to make power, not actually a generator), as the engine isn't running. I'd watch the voltage swing, the power steering unit, fuel pump, etc. will drawn down the tiny battery. You might be on that hairy edge where it matters. LEDs don't draw much current relative to electric motors. The relay shouldn't act any different. What happens when the engine is running?

Love the mod, by the way. Do you have a link to it??? Or a write-up?

(Lights on high-beam don't matter in the U.S., it's just a flapper that moves out of the way.)

Don't think that motorcycle jacket would work too well on a Slingshot... :confused:o_O

;):p:D
 

·
Registered
Joined
·
1,459 Posts
Discussion Starter #6
No write up ATT not until I clear this BUG. Want my fellow sling zombies to have a good working mod.
To answer your question I can drive it and its not until a use the turn signal or hazard that the whole signaling action stops. However I see your point on " You might be on that hairy edge where it matters" . This however will be easy to determine if I isolate this mod and add just for testing purpose some current drawing accessories. But then again these LEDs are small so lets see.
 

·
I have moved on!
Joined
·
2,900 Posts
No write up ATT not until I clear this BUG. Want my fellow sling zombies to have a good working mod.
To answer your question I can drive it and its not until a use the turn signal or hazard that the whole signaling action stops. However I see your point on " You might be on that hairy edge where it matters" . This however will be easy to determine if I isolate this mod and add just for testing purpose some current drawing accessories. But then again these LEDs are small so lets see.
Does the mod have its own module?
We ran into a problem with the front turn signal mod and it turned out to be the module on the kit
 

·
Registered
Joined
·
1,459 Posts
Discussion Starter #10
OK so I might have a solution ----- swapping out the SS electronic turn signal relay for a old school mechanical one "BRILLIANT ! "
Keep everyone updated as soon as this is done !
 

·
Registered
Joined
·
1,459 Posts
Discussion Starter #16
The truth I had a blue and gold many years ago the sucker lived 25 years in my care. Dam bird would scream like a mad man from 6 to 6:30 every frekin day .........it's name was Bandit .
 

·
Super Moderator
Joined
·
2,871 Posts
OK so I might have a solution ----- swapping out the SS electronic turn signal relay for a old school mechanical one "BRILLIANT ! "
Keep everyone updated as soon as this is done !
A bandage covers a problem, not fixes it. If you think it's a current-draw issue, disconnect the front light plug and see if the add-on LEDs work. If so add the relay, if not add a filter capacitor.

download (11).jpg

Band Aide​
 

·
Registered
Joined
·
1,459 Posts
Discussion Starter #20
Well as soon as I get my SS back from recalls and warranty work that's the first thing I 'll try.
Warranty : loose catalic converter " metal vibration noise " at certain RPM
Recall: double nut rear bearing, Polaris wants the double nut recall done first before having to change bearings, upgraded hood rubber pads and stoppers.
Gear oil change.
:vulcan:
Live long and Ride safe!
 
1 - 20 of 38 Posts
Top