Polaris Slingshot Forum banner
1 - 4 of 4 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 · (Edited)
Hi Everyone,

My brother just got a 2020 SL, I'm the family mechanic so I inherited all the issues but dont mind the joy rides 馃ぃ.

The check engine light was on constantly even after restart, reading through the forum and manual I followed the instructions to pull codes but there are no codes available using the Mode button and nothing under the diagnostic screen on the center display either. The only option available under mode setting is changing the backlight color, no "check eng" option available.

No issues while driving so I reset the code, took it out for a spin and check engine light has not come back. Any input? Or anyone had similar issue? As of right now its a reset and forget.

Thanks in advance.
 

Registered
Joined
5,329 Posts
Hi Everyone,

My brother just got a 2020 SL, I'm the family mechanic so I inherited all the issues but dont mind the joy rides 馃ぃ.

The check engine light was on constantly even after restart, reading through the forum and manual I followed the instructions to pull codes but there are no codes available using the Mode button and nothing under the diagnostic screen on the center display either. The only option available under mode setting is changing the backlight color, no "check eng" option available.

No issues while driving so I reset the code, took it out for a spin and check engine light has not come back. Any input? Or anyone had similar issue? As of right now its a reset and forget.

Thanks in advance.
I'm not a 'mechanic' just a guy who has been riding a Slingshot since Feb 2015 and 106,000+ miles in the seat. What we have found is that some of these codes just show up. Key off/on a couple of times will clear it. Sometimes need to disconect the battery for a couple of minutes. Had several time when out riding with friends and codes came up and couldn't keep it running until we disconect the battery --- rehooked and ran like a top. Welcome to the World of Slingshot Insanity.
 

Registered
Joined
90 Posts
Hi Everyone,

My brother just got a 2020 SL, I'm the family mechanic so I inherited all the issues but dont mind the joy rides 馃ぃ.

The check engine light was on constantly even after restart, reading through the forum and manual I followed the instructions to pull codes but there are no codes available using the Mode button and nothing under the diagnostic screen on the center display either. The only option available under mode setting is changing the backlight color, no "check eng" option available.

No issues while driving so I reset the code, took it out for a spin and check engine light has not come back. Any input? Or anyone had similar issue? As of right now its a reset and forget.

Thanks in advance.
Same with my 2020. Mine does it when I accidentally step on the brake and the gas at the same time. (I have big feet) Disconnecting the battery for a few minutes works.
 
1 - 4 of 4 Posts
Top