Polaris Slingshot Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi guys, wanted to see if anyone else is having this issue. I'm new on the board so I've been doing some searches prior to posting but did not see anything.

On the drive home from the dealer my dad was following behind me and called me to ask if I was riding the brakes because he sees them come on but it never lets up and the center tail light is always illuminated. When I got home and turned the vehicle off and on again the brakes light finally went off but when pressed they would just stay on even after it's released. Anyone having this issue? Today I had met another SS owner and I followed him and his was also doing it. This would explain why my cruise control would not engage I guess if the system thinks your pressing on the brakes and now the vehicle stability system is illuminated on the dash. I tried pushing the button and even pressing it for more than 5 seconds but nothing happens. A call to my dealer and they are absolutely clueless also. Anyone have any suggestions? Thanks.
 

·
Registered
Joined
·
513 Posts
Oh boy... I had the stability light came on me on the day I bought it. I shut the vehicle off and it went away. Happened couple of times but not lately. I'm not sure about the brake lights though. You should have the dealer look at the lights. I've heard several member's center brake light harness wasn't even connected.
 

·
Registered
Joined
·
1,207 Posts
Hi guys, wanted to see if anyone else is having this issue. I'm new on the board so I've been doing some searches prior to posting but did not see anything.

On the drive home from the dealer my dad was following behind me and called me to ask if I was riding the brakes because he sees them come on but it never lets up and the center tail light is always illuminated. When I got home and turned the vehicle off and on again the brakes light finally went off but when pressed they would just stay on even after it's released. Anyone having this issue? Today I had met another SS owner and I followed him and his was also doing it. This would explain why my cruise control would not engage I guess if the system thinks your pressing on the brakes and now the vehicle stability system is illuminated on the dash. I tried pushing the button and even pressing it for more than 5 seconds but nothing happens. A call to my dealer and they are absolutely clueless also. Anyone have any suggestions? Thanks.
Another thing to check before heading home, Thanks
 

·
Registered
Joined
·
2,014 Posts
You know, the thing that really bothers me? That a freaking dealer would be clueless. They should have told you to bring it right back, and have one of their techs look at it. That would be the least they should have done. But to tell a customer they don't know without at least looking at it?

Some of these dealers don't deserve to be in business....period.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
You know, the thing that really bothers me? That a freaking dealer would be clueless. They should have told you to bring it right back, and have one of their techs look at it. That would be the least they should have done. But to tell a customer they don't know without at least looking at it?

Some of these dealers don't deserve to be in business....period.
Thanks guys for your response.

I told them I was bringing it in and they said it would be 4 days before they can even look at it. Meanwhile the SS will be left outside in sun and rain. They will not even put you in the books unless you drop it off. So what's the sense of dropping it off if it just sits there.

I started checking myself and was able to find the brake switch and I think it might be a faulty switch unit that just won't release.
 

·
Registered
Joined
·
1,008 Posts
Hi guys, wanted to see if anyone else is having this issue. I'm new on the board so I've been doing some searches prior to posting but did not see anything.

This would explain why my cruise control would not engage I guess if the system thinks your pressing on the brakes and now the vehicle stability system is illuminated on the dash.


Not to go off topic but the SS has cruise control?? I guess i never noticed it on my TD....does the basic have this as well?
 

·
Registered
Joined
·
1,207 Posts
Thanks guys for your response.

I told them I was bringing it in and they said it would be 4 days before they can even look at it. Meanwhile the SS will be left outside in sun and rain. They will not even put you in the books unless you drop it off. So what's the sense of dropping it off if it just sits there.

I started checking myself and was able to find the brake switch and I think it might be a faulty switch unit that just won't release.
Grease ?
 

·
Registered
Joined
·
2,292 Posts
It's worth dropping off to see if the OBD returns any fault codes. It may not, but that's one of the first places I'd look after inspecting the sensors.
 
  • Like
Reactions: pjs

·
Registered
Joined
·
2,014 Posts
I really feel for all you guys with the schmuck dealerships. Four days before looking at it? That's utter nonsense. They could make an appointment, rather than let it set outside. Morons, that's what they are. Run don't walk to another dealership if you have the option.

Sounds like afreaking Harley dealership.
 

·
Registered
Joined
·
105 Posts
Check the brake sensor. You can find it in front of the ECU. It may have moved slightly. If it is registering input (it is a simple magnetic switch) then your lights will be on and the cruise will not work. Take a 10 mm wrench to the bolt and move your sensor (its a black slotted magnet) back and forth to find where the lights just turn off. You may have to play with it just a little bit but that should solve your problem. It could have been something that was bumped in shipping, when you hit a bump, or from the factory. Simple fix. Find that sweet spot and then torque her down.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
Check the brake sensor. You can find it in front of the ECU. It may have moved slightly. If it is registering input (it is a simple magnetic switch) then your lights will be on and the cruise will not work. Take a 10 mm wrench to the bolt and move your sensor (its a black slotted magnet) back and forth to find where the lights just turn off. You may have to play with it just a little bit but that should solve your problem. It could have been something that was bumped in shipping, when you hit a bump, or from the factory. Simple fix. Find that sweet spot and then torque her down.
I did find that switch and the slotted bracket, I will try that in the morning. Thank you for your suggestion.
 

·
Registered
Joined
·
1 Posts
I'm completely new to this forum and I've yet to purchase a SS.
After reading virtually everything on here, I've come to the conclusion that this product is virtually riddled with electrical as well as mechanical problems. It appears that the Polaris dealerships have as much problems as the product itsself. Their customer support appears to be really bad and unsatisfactory based on customer response on these forums.
I was ready to pull the trigger and lay down some bucks, but now I'm having second guesses.
 

·
Registered
Joined
·
1,470 Posts
Kevin, if you have read everything here then you know there are good and bad points to owning a SS right now. That's a personal decision, if you posted your doubts here waiting for someone to talk you into, or out of a SS, that's not going to happen. I don't understand the reason for your post, maybe I'm just having a bad night. Hopefully someone else can answer your non-question.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #18
Even with some of the issues I would not trade it for anything. It's one of the most fun vehicle out there. Don't forget also that your buying a 24k toy not a Bentley! Anything you buy has issues some more than others. Mine has been great other than the brake light sticking but I fixed it, now past 1600 miles and I wouldn't hesitate driving this cross country. Also remember your buying a first year production and in my mind I've accepted the fact that there will be some issues.
 

·
Registered
Joined
·
271 Posts
the good part of your message is you found this forum and all the help you could possible want ( and their not the dealers - they do it for free - because they care! ) BUT if your afraid to get your hands dirty , dont buy it - that gives another person a chance to get one who has been more than patient .

Doug
 

·
Registered
Joined
·
19 Posts
Thanks guys for your response.

I told them I was bringing it in and they said it would be 4 days before they can even look at it. Meanwhile the SS will be left outside in sun and rain. They will not even put you in the books unless you drop it off. So what's the sense of dropping it off if it just sits there.

I started checking myself and was able to find the brake switch and I think it might be a faulty switch unit that just won't release.
Did you go to a dealership to get a replacement switch or were you able to find it elsewhere. Mine is sticking and would like to switch it out. I don't mind working on my SS, a brake switch replacement should be pretty easy as long as I can get upside down and under the dash to get to it!
 
1 - 20 of 21 Posts
Top