Polaris Slingshot Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
513 Posts
Discussion Starter #1
I had the Brake Failure light came on today. Well that's a first. Pulled over and shut the engine off. Still on. Parked after a while then restarted it turned off. SS drove fine and did not notice anything unusual. Just like the stability control light it just randomly came on. Weird
 

·
Registered
Joined
·
2,014 Posts
As an Indian and Victory owner, I'm here to tell you, Polaris products throw goofy codes from time to time for no rhyme or reason. I take it with a grain of salt. If it throws a code and whatever it's warning about is still functioning, I pretty much ignore it. YMMV of course, so take what "I" say with that same grain of salt.
 

·
Registered
Joined
·
573 Posts
As an Indian and Victory owner, I'm here to tell you, Polaris products throw goofy codes from time to time for no rhyme or reason. I take it with a grain of salt. If it throws a code and whatever it's warning about is still functioning, I pretty much ignore it. YMMV of course, so take what "I" say with that same grain of salt.
Can Am Spyders are notorious for throwing codes also.
 

·
Registered
Joined
·
82 Posts
My lite came on a few days ago,it was a bit disconcerting to say the least. I was on the freeway at about 65 per. Pulled over to the shoulder trying the brakes as I pulled to a stop. Everything seemed fine. I shut off restarted and the lite was off. Went to lunch,headed home and the lite came on again. Tried the brakes a couple times and they seemed fine. Next day (this past Monday) went to the dealer and he says "oh yeah", he wasn't surprised. Said it was a switch in the master cylinder. He ordered the part and the parts for the harness and will give me a call when it all gets here. Meanwhile i'm driving it.
 

·
Registered
Joined
·
666 Posts
My brake failure light comes on every ride now after about 10 minutes of riding, nothing appears to be wrong
Might be moisture in brake fluid it gets hot and makes a air pocket in the fluid which feels like you need to bleed the brakes cold weather sometimes cause it
 

·
Registered
Joined
·
555 Posts
Brake failure light is annoying. Had mine fixed on Monday. At 65 mph, just key off and key on as you are driving. The engine will restart on its own. Some days, I would get the light every 5 minutes.

Took the dealer, about two hours, which includes a bleed. Didn't cost me a penny. Dealer had seen it before. So far, so good.


Sent from my brain using an iPad
 

·
Registered
Joined
·
82 Posts
Brake failure light is annoying. Had mine fixed on Monday. At 65 mph, just key off and key on as you are driving. The engine will restart on its own. Some days, I would get the light every 5 minutes.

Took the dealer, about two hours, which includes a bleed. Didn't cost me a penny. Dealer had seen it before. So far, so good.


Sent from my brain using an iPad
Dealer just called and said he had the parts for brake fix and harness fix, didn't know anything about rear axle nut.
 

·
Registered
Joined
·
555 Posts
Harness is 30 minutes. Rear axle nut, you may need a little time for the dealer to get 'em in stock. Tell the dealer you have rice crispies in the rear. If it is a good dealer,they will do the TSB. It is not a recall, so you may have to fuss a bit. A good dealer will cover your 6 on this issue.


Sent from my brain using an iPad
 

·
Registered
Joined
·
1,098 Posts
Brake failure light on,,,no cruise,,went to dealer,,parts back ordered approx date 1/22/16 ...i want my Cruise..haha....at least i can ride....:)
 

·
Registered
Joined
·
82 Posts
Took it to the dealer Tuesday, harness is squared away. He ordered the wrong part for the brake and will call me when it's in. Glad I'm only about 2 miles from the dealer.
 

·
Registered
Joined
·
1,281 Posts
If you set the cruise control before the light comes on it will still work. Before the new sensors were installed I got good at resetting the light at speed turning the key off and back on.
 

·
Registered
Joined
·
1,098 Posts
i am not sure if this really matters,,haha but the tech stopped the light from coming on, but as i was on the highway,,i figured it was fixed,,but when i went to do the cruise,,NOPE,,so he fixed part of it but not total,,something about a LEVEL Switch? in any case its back ordered ..:) thanks for replys..
 
1 - 20 of 28 Posts
Top