Polaris Slingshot Forum banner

1 - 20 of 47 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
I read other posts on the brake failure warning light coming on.. Heading out for a rally and trailering the SS. Just going to drive it around the rally location.. Brake fluid is full; no leaks; full brake pedal; the brake failure light comes on after using the brakes. It drives normal and brakes normal. Is it safe to drive?
 

·
Registered
Joined
·
396 Posts
Tom, I checked with my dealer before going to SSITS and the tech talked with Polaris about it. I drove it right at 1500 miles on the trip with no issues other than the cruise control not working when the light was on. The cure for that was to put it in neutral and shut it off for a few seconds and then restart it if I wanted to use the cruise.

I also believe Hardy is correct.
 

·
Registered
Joined
·
2,742 Posts
T The cure for that was to put it in neutral and shut it off for a few seconds and then restart it if I wanted to use the cruise.
Brakes? Steering? Cruise control? What other ailments will a simple shut down and restart, computer reboot), cure? ;)

Bill
 

·
Registered
Joined
·
1,098 Posts
I read other posts on the brake failure warning light coming on.. Heading out for a rally and trailering the SS. Just going to drive it around the rally location.. Brake fluid is full; no leaks; full brake pedal; the brake failure light comes on after using the brakes. It drives normal and brakes normal. Is it safe to drive?
just talked to a guy with same issue and it was a loose connection, and threw a brake failure light...jus sayin..:)
 

·
Registered
Joined
·
1,254 Posts
its a freakin joke, been on mine for over 700 miles polaris has no cure for this, 2 many STUPID comments, turn this off, turn that off, that doesn't help when your driving 75 mph on the hwy with a steady brake failure light on and you can't use cruise control, polaris engineers get off your lazy asses and fix this, as well as the ball bearings!!!!!!! i am pissed!
 

·
Registered
Joined
·
1,050 Posts
Mine is on also. I already took it to the dealer and they said they topped off the fluid. It turned back on as I drove away. I didn't have time to go back. I might go in today and see what happens.
 

·
Registered
Joined
·
5,299 Posts
I'll let you all know later this weekend. Mine is going in to have both the brake switches replaced for that same reason. Dealer said Polaris told them not to replace just one of the switches, but to do both at the same time. We'll see if that works, but it wouldn't surprise me to see contamination particles in the brake fluid inside the switches when they come out. JMHO
 

·
Registered
Joined
·
5,299 Posts
They did. Replaced both switches and no problem since. While I was there,I pointed out the black contaminated fluid (it uses the same brake fluid as the brake system). They drained the old fluid out and replaced it with new fluid and I left. Both systems are still working correctly. Sorry if I lead you down the wrong path there Stephen, Have a great week
 

·
Registered
Joined
·
658 Posts
I will be taking mine in this weekend to get checked out and the parts ordered. Just want to make sure what might have fixed it.

Thanks,
Stephen
 

·
Registered
Joined
·
2,055 Posts
Sure did. No problems since and they did a "drain and refill" of the clutch master to get the crap black DOT 4 fluid out of the system.
After a couple weeks no issue with Clutch as they did the same fix..
 
1 - 20 of 47 Posts
Top