Polaris Slingshot Forum banner
41 - 58 of 58 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #43 ·
Do you mean doing the December 2021 Ride Command Update again? My Sling is a 2022 Slingshot R. It should have come with it from the factory. I have Nav/traffic etc. I saw for some others the Dec 2021 update actually broke CarPlay
Yes I would assume that your vehicle should have come with CarPlay. Mine is a 2020 and I was able to get it simply by upgrading the software on the command.
 

·
Registered
Joined
·
164 Posts
@JMRE What software version do you have on your Slingshot?

DEC 2021 = SLS7A9.S22145A
DEC 2020 = SLS7A9.S12050A

You may know but to check software version go to:
  • Tap the Slingshot logo at the top of the screen, then press "All Settings".
  • Tap "General" from the tabs on the left.
  • Scroll down to "Update Software" and it should tell you the current version


I have yet to find a person with the DEC 21 update that has Carplay working. So please let me know if it is you pls
 

·
Registered
Joined
·
42 Posts
Did you ever find a fix? I am going to put in a ticket with Polaris but wondering if you found the culprit or a work around to get carplay working?
I have the latest update and I can still use Apple Car Play, but I need to manually connect the bluetooth device all the time now in the ride command bluetooth settings menu. Prior to the update I wouldn't need to manually connect as often.
@JMRE What software version do you have on your Slingshot?

DEC 2021 = SLS7A9.S22145A
DEC 2020 = SLS7A9.S12050A

You may know but to check software version go to:
  • Tap the Slingshot logo at the top of the screen, then press "All Settings".
  • Tap "General" from the tabs on the left.
  • Scroll down to "Update Software" and it should tell you the current version


I have yet to find a person with the DEC 21 update that has Carplay working. So please let me know if it is you pls
My SS is a 2021 RL and I have version SLS7A9.S12044A and Apple Car Play is working.. Dealer told me they had to update the ride command software when I took it in a week after I bought it in March 2021 to fix an issue with audio cutting off all the time... Looks like I am running a code version older than Dec 2020??
 

·
Registered
Joined
·
2 Posts
I'm curious too. I got the software update done (along with paddle shifters) to my 2020 - the dealer said they only got it to work once and had to connect bluetooth headset and the usb cable to the iPhone. I tried with my AirPods pros and never could get it to work. It's stupid that the Polaris requires a headset to allow apple CarPlay to work in the first place. I've got a pair of beats I'll try shortly but I'm overall very annoyed that it doesn't work at least not easily.
I had to download the ride command software from 2020 and then connect my AirPods via Bluetooth to the slingshot and usb my phone to the slingshot. The Dec 2021 update makes it so the car play is not recognized.
 

·
Registered
Joined
·
7 Posts
Before hiring a cross-platform app development company mlsdev.com/blog/healthcare-mobile-app-development , you should ask about the team's background and customer group. If possible, find out how many cross-platform apps they have successfully developed, and which features they prioritized. If possible, choose a team that has developed similar apps. A cross-platform app development company with the same experience and culture as yours should be able to deliver your app quickly and efficiently.
 

·
Registered
Joined
·
164 Posts
I have the latest update and I can still use Apple Car Play, but I need to manually connect the bluetooth device all the time now in the ride command bluetooth settings menu. Prior to the update I wouldn't need to manually connect as often.


My SS is a 2021 RL and I have version SLS7A9.S12044A and Apple Car Play is working.. Dealer told me they had to update the ride command software when I took it in a week after I bought it in March 2021 to fix an issue with audio cutting off all the time... Looks like I am running a code version older than Dec 2020??
Hey @tomb I am going to try downgrading to the 2020 software tonight. From you post you said you were on the latest update (Dec 2021) then you stated you are on a version older than the DEC 2020 version :) which is it?
 

·
Registered
Joined
·
2 Posts
Hi All, newbie here. I have a 2022 SLR. How can I change between headset and speaker, while in Carplay mode?
The Carplay luckily works, but when it turns on, I cannot seem to find a way to switch between the headset and the speaker. I only find that button when I am in bluetooth mode (i.e. no Carplay)... thanks for your help!
 

·
Registered
Joined
·
164 Posts
I will check today but I recall that you can get back to the normal media player screen if you tap the Slingshot Icon while in Carplay. Also @Dan123 what version of the Ride Command software are you running.

DEC 2021 = SLS7A9.S22145A
DEC 2020 = SLS7A9.S12050A

You can find this in Settings -> General -> Software
 

·
Registered
Joined
·
2 Posts
Hi derichio02 - I have the Dec 2021 software. When I have my phone plugged in, carplay takes over the media player as well. I was able to find the SS icon, but that only gives me option to change display brightness and switch between comfort vs slingshot mode. Thanks Dan
 

·
Registered
Joined
·
164 Posts
Ok so update for anyone that is following. My Carplay did not work when my 2022 R was delivered. It had the DEC 21 software. I downgraded the software to the DEC 2020 version and viola, my Carplay began functioning. I then took the risk of re-updating to the DEC 2021 version and low and behold Carplay is still functioning perfectly! The 2021 Software is much faster and has a better response time than the 2020 version.

Try at your own risk, albeit small from my experience, but this method worked for me.
 

·
Registered
Joined
·
48 Posts
You’re the man! Also, I got mine to work with my apple air pods pro and a couple other newer headsets so they should work with other headphones as well! Thanks for your help on this!
Was wondering if you can tell me what I'm doing wrong? I paired my air pod pro and plugged the iPhone in using the usb port. When I go into Bluetooth menu on the SS I see both devices but when I select the carplay menu I still have the generic message saying I need a headset and the iPhone connected. the carplay button is grayed out...
 
41 - 58 of 58 Posts
Top