Polaris Slingshot Forum banner
21 - 40 of 64 Posts

·
Registered
Joined
·
42 Posts
What I found was that audio would only go through the Bluetooth headset and not the speakers on the SS, there is an option to switch between the two but that didn’t work for me. I was using an old cheap Bluetooth device and the SS ride command system was not liking it, would give me 5 mins of CarPlay and then disconnect. I’ll probably just get a mount for the phone that has wireless charging built in, until I find a solution.
 

·
Registered
Joined
·
8 Posts
I ordered the cheapest sena from their list.. $165!! Crazy. I hope to leave it in the glove
Box charging and connected and then be able to connect to CarPlay fairly easily anytime. We’ll see. Problem is I rent mine out and don’t really want to leave an expensive headset in there just so CarPlay works!
 

·
Registered
Joined
·
8 Posts
Is there a headset out there that I can keep plugged in the glovebox and will automatically turn on and connect each time turn on the slingshot? I'd hate to have to buy a headset, open the glove box and pair the headset each time just to get CarPlay to work. I hope someone creates a bypass at some point. Disappointed finding all this out after I purchased mine.
 

·
Registered
Joined
·
42 Posts
Is there a headset out there that I can keep plugged in the glovebox and will automatically turn on and connect each time turn on the slingshot? I'd hate to have to buy a headset, open the glove box and pair the headset each time just to get CarPlay to work. I hope someone creates a bypass at some point. Disappointed finding all this out after I purchased mine.
Yes I just got it working here is what I bought and some pics. https://www.amazon.com/dp/B07GB7298K?ref=ppx_pop_mob_ap_share

*FYI, if you let it sit a long time in between rides, prior to starting the SS just open the glove box and press the button until it flashes blue, then start the SS and it will auto connect. If riding and taking short stops, will not be an issue.

185323
185324
185325
185326
 

·
Registered
Joined
·
42 Posts
awesome. Just what I was looking for. I ordered it. Thank you so much for the post.
Nice, my next goal is to get wireless Apple car play working so I don’t need to plug in the phone at all. I’ll post my results after a I get the devices and test.
 

·
Registered
Joined
·
172 Posts
Like others has said, you phone has to be wired to the USB under the Ride comman system and you also need a bluetooth receiver as carplay does not work without a headset. I dont care about talking I just wanted maps and music so I just purchased a bluetooth the receiver and have it connected in the power port in the glove box. Ensure that you connect to the paired receiver before plugging your device in.

Here is the receiver I used it also has USB power ports so you don’t lose those: https://www.amazon.com/gp/product/B07GJ7DHMP/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

Update: I didnt see page 2 before posting but this device works as well :)
 

·
Registered
Joined
·
1 Posts
Yes I just got it working here is what I bought and some pics. https://www.amazon.com/dp/B07GB7298K?ref=ppx_pop_mob_ap_share

*FYI, if you let it sit a long time in between rides, prior to starting the SS just open the glove box and press the button until it flashes blue, then start the SS and it will auto connect. If riding and taking short stops, will not be an issue.

View attachment 185323 View attachment 185324 View attachment 185325 View attachment 185326
Can you make a short video on how to connect it all? Does the music still come Out of the speakers?
 

·
Registered
Joined
·
8 Posts
Can you make a short video on how to connect it all? Does the music still come Out of the speakers?
Finally got my 2020 SL CarPlay working use that 12v Bluetooth adapter someone linked to.

Thanks!!

Link the Bluetooth adapter to the slingshot first
Then plug-in phone and phone should pop up and ask if you want to allow CarPlay. If it doesn’t, unplug the phone, turn off the sling and crank it again and make sure the Bluetooth adapts connected then plug in the phone again.
 

·
Registered
2020 R Autodrive
Joined
·
97 Posts
I am not having a lot of luck with this maybe I am just to old. The BT07 connected to the Slingshot and under Bluetooth settings it says BT07 and my IPhone is connected under Bluetooth also and with the USB cable to the BT07.. When I select CarPlay it says I need a Bluetooth headset connected. I have i!2 earbuds but can't get them to pair. Have them in their charger box right now. What did I miss?
 

·
Registered
Joined
·
3 Posts
Finally got my 2020 SL CarPlay working use that 12v Bluetooth adapter someone linked to.

Thanks!!

Link the Bluetooth adapter to the slingshot first
Then plug-in phone and phone should pop up and ask if you want to allow CarPlay. If it doesn’t, unplug the phone, turn off the sling and crank it again and make sure the Bluetooth adapts connected then plug in the phone again.
I got it to finally work but with no sound. How’d you get yours to play music or maps with the sound through the speakers?
 

·
Registered
Joined
·
42 Posts
Did you get sound through your speakers?
You have to make sure that you switch the slider from headphone symbol to speaker symbol, see picture below. Top right corner (Do this before you plug your phone in, I did when on FM)
185544
 

·
Registered
Joined
·
3 Posts
You have to make sure that you switch the slider from headphone symbol to speaker symbol, see picture below. Top right corner (Do this before you plug your phone in, I did when on FM)
View attachment 185544
You’re the man! Also, I got mine to work with my apple air pods pro and a couple other newer headsets so they should work with other headphones as well! Thanks for your help on this!
 

·
Registered
Joined
·
5 Posts
So I had my carplay working fine with a disconnect here and there. So I decided to try the update that was released in December 2021, well now my ride command units recognizes my headset is connected (I see the headset icon) however, carplay will not work, no carplay pop up on my phone or anything. when I plug phone in via cable it will play music but just no apple carplay
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #38 ·
So I had my carplay working fine with a disconnect here and there. So I decided to try the update that was released in December 2021, well now my ride command units recognizes my headset is connected (I see the headset icon) however, carplay will not work, no carplay pop up on my phone or anything. when I plug phone in via cable it will play music but just no apple carplay
So frustrating!
 

·
Registered
Joined
·
172 Posts
So I had my carplay working fine with a disconnect here and there. So I decided to try the update that was released in December 2021, well now my ride command units recognizes my headset is connected (I see the headset icon) however, carplay will not work, no carplay pop up on my phone or anything. when I plug phone in via cable it will play music but just no apple carplay
Same! Not sure how to resolve yet did you get it working?
 

·
Registered
Joined
·
172 Posts
So I had my carplay working fine with a disconnect here and there. So I decided to try the update that was released in December 2021, well now my ride command units recognizes my headset is connected (I see the headset icon) however, carplay will not work, no carplay pop up on my phone or anything. when I plug phone in via cable it will play music but just no apple carplay
Did you ever find a fix? I am going to put in a ticket with Polaris but wondering if you found the culprit or a work around to get carplay working?
 
21 - 40 of 64 Posts
Top