Polaris Slingshot Forum banner

1 - 20 of 160 Posts

·
Registered
Joined
·
797 Posts
Discussion Starter · #1 ·
So myself, TheRock and Jdin installed my alpha supercharger. The next day as I was heading home from work, something went terribly wrong. I was going down the road coming off an exit..was in 2nd gear doing about 50 or so and as I hit the gas to merge over, poof...smoke and engine cutoff.. I coasted to the side of the road and popped the hood. Oil was all over the left side of the engine and I noticed my 2 bar map sensor had been blown out of its port. Not sure what went wrong. Bummer!
 

Attachments

·
Registered
Joined
·
2 Posts
So myself, TheRock and Jdin installed my alpha supercharger. The next day as I was heading home from work, something went terribly wrong. I was going down the road coming off an exit..was in 2nd gear doing about 50 or so and as I hit the gas to merge over, poof...smoke and engine cutoff.. I coasted to the side of the road and popped the hood. Oil was all over the left side of the engine and I noticed my 2 bar map sensor had been blown out of its port. Not sure what went wrong. Bummer!
Wow! I'm really sorry to hear about your problem. I know you must've been so happy to have the supercharger installed. Life was good .... then THIS! So, so sorry!
 

·
Registered
Joined
·
797 Posts
Discussion Starter · #5 ·
Wow! I'm really sorry to hear about your problem. I know you must've been so happy to have the supercharger installed. Life was good .... then THIS! So, so sorry!
yep.. worked perfectly for 1 day and then poof..
 

·
...............................
Joined
·
2,333 Posts
I'll be interested to hear what went wrong, it sounds like something in the tune to make it detonate, sorry for your loss hope it gets fixed.
same here..im at a loss right now.
Sorry to hear about your loss ......... unfortunately I believe you answered your own question .....

2 bar map sensor had been blown out of its port
No pressure reading to ECU = no fuel enrichment .....and ....... :(

.
 

·
Registered
Joined
·
41 Posts
I was going down the road coming off an exit..was in 2nd gear doing about 50 or so and as I hit the gas to merge over, poof.
It's been a long winter so I haven't been in my SS in a while... "2nd gear doing about 50"... how many RPM is that? And then any chance you over rev'd when you "hit the gas to merge?"
 
1 - 20 of 160 Posts
Top