Polaris Slingshot Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
OK, I have a 2015 base model, and I've noticed that in 4th and 5th gear between 1300 and 1800 RPM's that the accelerator will continue, for approximately 2 to 3 seconds after I let off the gas pedal. If I hit the brakes or down shift it stops immediately. At first it was sporadic at best now it seems to be more common. Has anyone else experience this with their Slingshot, and is there some kind of bulletin or recall for this?

Jim Brock
 

·
Registered
Joined
·
4,840 Posts
I wonder if there is a throttle position sensor problem that causes the delay you reported. Recommend a call to your dealer.
 

·
Registered
Joined
·
1,220 Posts
There was an updated tune from the original 2015 model, have a Dealer check what tune is in yours or just get a new tune installed. Very common problem in 2015.
 

·
Registered
Joined
·
388 Posts
There was an updated tune from the original 2015 model, have a Dealer check what tune is in yours or just get a new tune installed. Very common problem in 2015.
thanks Phil Mines starting to hang up a bit too , also a 2015, will check tunes , dealer is finally getting my recall parts in now
 

·
Registered
Joined
·
1,006 Posts
Remove the air intake hose and check the throttle body butterfly. See if there is any gunk in the hinge or where the butterfly meets the body.

I'm thinking this is not the issue at hand, as this gunking usually sticks when the butterfly is closed and you try to open it (press the pedal), but it wouldn't hurt to check it out.
 

·
Registered
Joined
·
2,689 Posts
I have noticed that problem a few times on my 2017. Usually slowing down in 3rd or 2nd gear. Not often or bad enough to talk to dealer yet.
I would still notify the dealer where they may start doing a lil researching?

Bill
 

·
Registered
Joined
·
21 Posts
Mine is a 2016 with only 1500 miles and im getting the RPM sticking as well. Also my light that says break failure came on the other morning while i was on the highway. I pulled over turned it off and checked fluids and break lines etc. Did not see anything started it back checked to see if i had breaks and light was not on anymore. Got to my destination and back home and it didn't come back on again. Not a good thing especially when your driving 70 and light comes on for break failure.
 

·
Registered
Joined
·
8 Posts
Mine is a 2016 with only 1500 miles and im getting the RPM sticking as well. Also my light that says break failure came on the other morning while i was on the highway. I pulled over turned it off and checked fluids and break lines etc. Did not see anything started it back checked to see if i had breaks and light was not on anymore. Got to my destination and back home and it didn't come back on again. Not a good thing especially when your driving 70 and light comes on for break failure.
I had that problem also, dealer replaced a brake pressure sensor switch. Common problem they said.
 

·
Registered
Joined
·
16 Posts
OK, I have a 2015 base model, and I've noticed that in 4th and 5th gear between 1300 and 1800 RPM's that the accelerator will continue, for approximately 2 to 3 seconds after I let off the gas pedal. If I hit the brakes or down shift it stops immediately. At first it was sporadic at best now it seems to be more common. Has anyone else experience this with their Slingshot, and is there some kind of bulletin or recall for this?

Jim Brock
OK, I have a 2015 base model, and I've noticed that in 4th and 5th gear between 1300 and 1800 RPM's that the accelerator will continue, for approximately 2 to 3 seconds after I let off the gas pedal. If I hit the brakes or down shift it stops immediately. At first it was sporadic at best now it seems to be more common. Has anyone else experience this with their Slingshot, and is there some kind of bulletin or recall for this?

Jim Brock
Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 

·
Registered
Joined
·
16 Posts
I had that problem also, dealer replaced a brake pressure sensor switch. Common problem they said.
Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 

·
Registered
Joined
·
16 Posts
Mine is a 2016 with only 1500 miles and im getting the RPM sticking as well. Also my light that says break failure came on the other morning while i was on the highway. I pulled over turned it off and checked fluids and break lines etc. Did not see anything started it back checked to see if i had breaks and light was not on anymore. Got to my destination and back home and it didn't come back on again. Not a good thing especially when your driving 70 and light comes on for break failure.

Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 

·
Registered
Joined
·
16 Posts
I have noticed that problem a few times on my 2017. Usually slowing down in 3rd or 2nd gear. Not often or bad enough to talk to dealer yet.

Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 

·
Registered
Joined
·
16 Posts
My 2016 has the same issue

Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 

·
Registered
Joined
·
16 Posts
My 2015 sl has been hanging also for several weeks now. Dealer said my ecu is up to date. Frustrating!


Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 

·
Registered
Joined
·
16 Posts
My 2015 sl has been hanging also for several weeks now. Dealer said my ecu is up to date. Frustrating!

Hi,
This same thing is happening to my 2016 Polaris Slingshot and has been at a licensed Polaris shop for over 2 months and they can’t seem to fix it even though they opened a claim with Polaris for tech support. They are aware of this dangerous issue and aren’t doing anything about it. Submit your claim to the government so they will be responsible for fixing it. They may have been lives lost from their negligence.

 
1 - 20 of 21 Posts
Top