Polaris Slingshot Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
236 Posts
Discussion Starter #1
My traction control light and ABS brake light came on. And now I don't have traction control or ABS brakes. I'm trying to get the scanner to see what's going on

Does anyone have any idea why both of those lights came on simultaneously, and both of those things stopped working?
 

·
...............................
Joined
·
2,331 Posts
My traction control light and ABS brake light came on. And now I don't have traction control or ABS brakes. I'm trying to get the scanner to see what's going on

Does anyone have any idea why both of those lights came on simultaneously, and both of those things stopped working?
Is it throwing any codes .....

Can someone look up check engine codes ?

.
 

·
Registered
Joined
·
236 Posts
Discussion Starter #3
So far I am not able to get any of the dealers to put the scanner on it "they are too busy" as far as I am concerned, from my experience the Polaris dealers are completely useless they act like they're doing you a favor and I literally can't get anything done with them
 

·
...............................
Joined
·
2,331 Posts
.

While running use the "mode" button in the center console to toggle through and see if "Ck ENG" shows up .... if it does hold down the mode button to see if the ECU is throwing a code ....

.
 

·
Registered
Joined
·
236 Posts
Discussion Starter #5
Nobody also has had this happen ?

Where is the ABS brake light and the traction control light comes on simultaneously and neither of those things work any longer ?

Anyone?
 

·
Registered
Joined
·
66 Posts
My traction control light and ABS brake light came on. And now I don't have traction control or ABS brakes. I'm trying to get the scanner to see what's going on

Does anyone have any idea why both of those lights came on simultaneously, and both of those things stopped working?
My brake failure light and traction control came on same time, dealer said it was a warranty issue, also my cruise won't work either with those lights on, I called them and set up an appointment to have it fixed, the bike is their right now getting that fixed, a fuel line recall and something else, all under warranty, should get back Wednesday, I hate hearing how some of these dealers are giving everyone the runaround, Indian of New Orleans has been nothing less than awesome with their service, quick, knowledgeable, friendly, you name it!
 

·
Registered
Joined
·
4,657 Posts
So far I am not able to get any of the dealers to put the scanner on it "they are too busy" as far as I am concerned, from my experience the Polaris dealers are completely useless they act like they're doing you a favor and I literally can't get anything done with them
Don't know where you are located, but there are lots of good dealers out there taking care of recall/warrantee issues very nicely. Has your Slingshot had the recall work done? The break light for sure is a recall issue....
 

·
Registered
Joined
·
236 Posts
Discussion Starter #9
I went to 2 dealers near me and I think it is safe to say they are completely useless, there is one other dealer here on Long Island and I will call them tomorrow , the 2 I spoke to are not only not very helpful but they are not very knowledgeable either
 

·
Registered
Joined
·
4,657 Posts
My preferred dealer is a nice 120 mile drive from my home...I live Southeast of Chicago and drive around the city to a dealership on the Northwest portion of the area. Nielsen's in Lake Villa, IL....
Super Dealer, Super Service. I can get some work done by some dealers a little closer but for my time and money it's worth the drive,
for super knowledge and skill in the service department.

Great dealers are out there, just need to find one...

You bought a unique vechiel which needs a little special care....


I've put 44,000+ miles on Slingshot since Feb 2015 and have enjoyed
every mile, even with some of the minor problems.
 

·
Registered
Joined
·
263 Posts
This could be a few different things. The Brake light could be related to the common switch issues the Sling has and may require the brake switches to be replaced. Usually that turns on the brake failure light as well. Could also be a bad sensor for the ABS or a faulty brake switch.

The traction control light will come on for various reasons one main one is the wheel speed sensors aren't reading correctly. Each wheel speed is read and all should be reading nearly identical. If one shows a much lower or higher speed then the light comes on and traction control is disabled. This happened to my new SLR. Turns out the whole hub assembly on the right front wheel was bad. Whatever happened the sensor wouldn't read the hub properly so it showed a different wheel speed on the right front triggering the traction light. This can also happen if you have to big a diameter differential based on tire sizes from front to rear. You can only have a variance of about 1" of diameter difference between front and rear otherwise the speeds the wheels sensors read go outside the normal parameters and that effects the ability of the stability control to accurately make corrections. Stability control looks at wheels speeds to detect slides/loss of traction to turn on the traction control and get the machine back under normal operation. That's why when you do a burnout for example the rear spins up way faster than the front and traction control reigns it back in. This could also be a wheel speed sensor.

Any of those require a scanner to see what the ECU is reading from those various sensors. It will be pretty obvious once scanned where it thinks the problem is. Gotta love technology...
 

·
Registered
Joined
·
92 Posts
Mine did it to with the bigger rims and tires like Phantom is referring to. Had to go to dealer and have the computer reset to sl model. lights went off, no issues since
 

·
Registered
Joined
·
2,455 Posts
Mine did it to with the bigger rims and tires like Phantom is referring to. Had to go to dealer and have the computer reset to sl model. lights went off, no issues since
There is something about the wheel size combo of the new wheels compared to the old that causes this.

I went with this (and love them) and they specifically state will not cause issues with ESP/ASC/TRAC and they don't. Put them on and never had an issue.

I think the people that are having issues are going to like 20" all around, that type of deal.

Custom Wheels for Polaris Slingshot 20 Inch Front 22 Inch Rear Wide Fat Wheel tire 345 Rear 20x12 20x8.5 20x9 Rim Rims Forged Aluminum Tires Package Set Mounted Racing widest rear available fattest biggest most traction possible
 

·
Registered
Joined
·
263 Posts
Yeah you have to do a little math when getting the tires changed out to larger ones. There are sites you can plug in the tire sizes and it will tell you what the diameter is. Just make sure front to rear the diameter difference is no more than an about an inch other wise the light comes on.

Most likely if it's stock tires a wheel speed sensor is bad or possibly a hub is bad giving a bad reading.
 

·
Registered
Joined
·
1 Posts
My traction control light and ABS brake light came on. And now I don't have traction control or ABS brakes. I'm trying to get the scanner to see what's going on

Does anyone have any idea why both of those lights came on simultaneously, and both of those things stopped working?
Well my 2016 slingshot had the abs and traction control light on as well but before I
My traction control light and ABS brake light came on. And now I don't have traction control or ABS brakes. I'm trying to get the scanner to see what's going on

Does anyone have any idea why both of those lights came on simultaneously, and both of
My traction control light and ABS brake light came on. And now I don't have traction control or ABS brakes. I'm trying to get the scanner to see what's going on

Does anyone have any idea why both of those lights came on simultaneously, and both of those things stopped working?
My 2016 had the same issue today but before I panicked I checked all the abs sensors and one of them was chipped at the connection I guess from driving it pickes up rocks and one must of hit it there the connection was also loose so I just snapped it back in and good as new they are connected on the inside of wheel cant miss it
 
1 - 16 of 16 Posts
Top