Polaris Slingshot Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
Can anyone tell me how to take the 3rd light out of my 2017 slingshot and how to trouble shoot it? It doesnt work at all but the other brake lights work. Any help would help. Do the roll bar hoops have to come off or what? Please help!!!!! Is the 3rd brake light connected to the backup camera cover?
 

·
Registered
Joined
·
214 Posts
Can anyone tell me how to take the 3rd light out of my 2017 slingshot and how to trouble shoot it? It doesnt work at all but the other brake lights work. Any help would help. Do the roll bar hoops have to come off or what? Please help!!!!! Is the 3rd brake light connected to the backup camera cover?
If I remember correctly.... Look at the third brake light follow it upwards toward the roll hoops. It turns into a plastic strip. Keep going until that strip goes into the passenger compartment. Look under the end of the strip and there is an torks bolt to unscrew. Then lift off the plastic strip. I believe you have to remove the backup camera too, to access another bolt. Search YouTube and you will find videos to help you remove the camera.
 

·
Registered
Joined
·
349 Posts
If you have the Polaris factory radio it is probably not the 3rd brake light that is bad (also known as the CHMSLCenter-High Mounted Stop Light), more than likely it is the antenna connector located on the rear frame deck driver's side of the back-up camera. The item is #16 on the page listed below. This connector is connected to the radio antenna AND the CHMSL and is easily damaged during installation. It must be grounded to the frame with the screw that you will see. it is possible that the screw has come loose and the connector is ungrounded OR the connector has been damaged internally by OVERTIGHTENING the screw. The torque for the screw is 15 INCH Pounds (Just snug enough to maintain ground)
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
I found it by taking off the license plate bracket and the plastic between the rear lights n runs under then n over to each side. Took the torx bolts out n bracket off n slide it out looks like i have a bad plug or connection. Pull it apart snaped it back together a had brake light . Put it back together n had none again but i tapped the light at the end n came on so its loose somewhere. So hey thanks for the help.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Yep i think thats whats wrong i think the one wire is broke inside i push on the connector n it works but when i wiggle the wires that got into the chmsl the 3rd light goes on n off so thanks alot n looks like i will buy a new one
 
1 - 5 of 5 Posts
Top