Polaris Slingshot Forum banner

41 - 45 of 45 Posts

·
Registered
2020 R Autodrive
Joined
·
94 Posts
There is a procedure in the manual to activate the alarm if it hasn't been used for 7 days . It is like press start button twice then Left turn signal then right turn signal then bights on and off. I have reset mine many tines as it will only stay active a few days. I used it yesterday and it worked today it didn't anymore. The fob still works so you can start with out entering the PIN.
 

·
Registered
Joined
·
45 Posts
I am having no more issues with the Alam/FOB. I did have to replace the CR2032 battery in the FOB as it was cheap/weak from the beginning. But its nice its a common battery and not some custom pain. Works great now.
 

·
Registered
Joined
·
19 Posts
I have a 2021 R LE and have same issues. Can someone post a video of what the feedback from the SS is when you press the lock button and then when you press the unlock button? All I could find is the following video:
 

·
Registered
Joined
·
19 Posts
I separated the FOB from the Slingshot and the alarm didn’t work as designed. Then I returned to the Dealer and had him to duplicate the same thing (with the vehicle separated from the FOB) and he also verified that the alarm was not functioning properly. I once again (for the fourth time) contacted corporate and the want the dealer to contact them. I’ve been going in circles with this issue but I’m not giving up.
I had my 2020 SL Auto-Drive into the Shop last week. After the Software Update, the Alarm system is working every time. Also transmission shifting better, no low speed clunking at Stop and no more bogging under heavy accel while passing. A new problem did start though, it now takes much more accelerator pedal to get the vehicle moving. Called Dealer and Polaris, hope to get a call back tomorrow from Dealer. Polaris did not help !
 
41 - 45 of 45 Posts
Top