Polaris Slingshot Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have had my 2020SL 4 months now. A few weeks after I first got it, I went to start it and the Driver info center said "Fuel pump priming, wait to start" So I did and it started no problem. After that it seemed that if I let it sit for a few days it would do the same thing. Its 4 months old now and every time I start it it needs priming even if i let it sit for a few minutes after running. Could I have a check valve in the fuel rail bleeding back?
 

·
Registered
2020 Slingshot Grand Touring Chan Chew Two
Joined
·
779 Posts
I have had my 2020SL 4 months now. A few weeks after I first got it, I went to start it and the Driver info center said "Fuel pump priming, wait to start" So I did and it started no problem. After that it seemed that if I let it sit for a few days it would do the same thing. Its 4 months old now and every time I start it it needs priming even if i let it sit for a few minutes after running. Could I have a check valve in the fuel rail bleeding back?
if you hit the start button without putting your foot on the brake It goes into the pump priming mode. That is for when you let it run out of gas and need to prime the pump before you restart it!
 
  • Like
Reactions: xd675x

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Actually it does this when I hit the break before I push the start button. It didn't do this when it was new, now it does it all the time.
 

·
Registered
Joined
·
11 Posts
Hmmm ... I'll check on that the next time I have Techline on the phone ... and that will be tomorrow .. lol .. Haven't heard any thing on that and we have at least 40 of the 2020's in circulation ....
 

·
Registered
Joined
·
4,783 Posts
Hmmm ... I'll check on that the next time I have Techline on the phone ... and that will be tomorrow .. lol .. Haven't heard any thing on that and we have at least 40 of the 2020's in circulation ....
Good to have you on the forum....
 

·
Registered
2015 2JZ swapped
Joined
·
415 Posts
All the new 2020's do that. Part of the priming is actually the little pump for the transmission building pressure in order to be able to auto-shift. This is all normal. The older Slings also had a short fuel pump priming procedure, the screen just didn't tell you.
 

·
Registered
Joined
·
128 Posts
The first week that I had my 2018 SL, it came up with a code (no, I do not remember it . . . maybe 6XXXX something). I finally tracked it down to this: When you turn the switch on, wait for the tach and speedo hands to go full right and then back to rest. You can hear the fuel pump during this time. I did it that way, code gone, never came back.
YMMV
 
1 - 9 of 9 Posts
Top