Polaris Slingshot Forum banner

21 - 27 of 27 Posts

·
Registered
Joined
·
1,025 Posts
When mine failed to start I was 180 miles from home, on Saturday. What a sinking feeling! Above in thread #12, R Lough says: "He jumped the connection under the hood where the clutch switch plugs in and it started right up". I know were that connection is, its easy to get to, but I haven't the slightest notion how to "jump the connection". Is that something easy to do, like connect the two terminals, if I get a non-start again?

Secondly, if the other end, which you can see one edge of with hood up, is magnetic would touching that edge with a strong magnet likely engage/activate it?
 

·
Registered
Joined
·
1,025 Posts
Ok, I figured how to jump the connection and made a wire to keep in dash in case it happens again.
 

·
Registered
Joined
·
1,025 Posts
Called the Svc Tech at my dealer today and they'd never had any problem with that switch and didn't think there was any way to check it at this time. I asked if it would hurt to spray the magnetic end with CRC Electronic spray and was given the ok. I've done that as a preventative measure.
 

·
Registered
Joined
·
18 Posts
I just used a cotter pin. The're flat and fit right in. You can also put it on a small key ring and store it in the glovebox.
Randy
 

·
Registered
Joined
·
1,025 Posts
I just used a cotter pin. The're flat and fit right in. You can also put it on a small key ring and store it in the glovebox.
Randy
Dang, good idea...…..I'd never have thought of that! :D
 
21 - 27 of 27 Posts
Top