Polaris Slingshot Forum banner

2016 slingshot is dead

2993 Views 8 Replies 5 Participants Last post by  Edcal
I went to start my slingshot yesterday for the first time and it would not do anything. So i worked on it for about 3 hours after charging the battery. It still would not start and i no there is power at the starter i check the solenoid and i got it to turn but it would not engage the started. Today i decided to tow it do the road to start it. Me and my neighbor went about a mile with the machine clutch out in 3rd gear and it did not pop once.
1 - 3 of 9 Posts
Have you put a voltage meter on the battery to determine the voltage? And please don't take this the wrong way but was the key in the 'on' position when you towed it?
yes it was 12.98 and then i tried starting it and the volts drop to 12.18 yes the key was on and i checked everything several times. Good news i pulled out a few fuses in the engine comp and i pulled out the starter relay mod then i tested terms with a meter and i could not tell what was going on with it. 1 pair of term showed ohms. So then i went and tested what that mod plugged into. i was getting some real high ohms reading on the first pair of terms then i switched me meter to volts readings as soon as i did that i heard a click and then a faint high noise for about 20 secs. So I put the mod back in.then i got in the drivers seat switched it on pushed the clutch down hit the starter button and Every thing clicked on and it started right up
I would also make sure your clutch switch is working properly
it is i checked continuity then i checked the volts of the feed lead to the clutch switch and i got 11.8v
1 - 3 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.