New Horn causes cruise control to quit

Discussion in 'Polaris Slingshot Discussions' started by MRD, Apr 20, 2017.

  1. MRD

    MRD Well-Known Member

    Joined:
    Oct 3, 2016
    Messages:
    357
    Thanks Received:
    153
    Trophy Points:
    98
    Location:
    Lynden WA
    When I bought my SS the first thing I did was to run a 6 guage wire from the new full size Optima battery to a custom made fuse box. It is set up to have both ignition and power fuses to run all of my accessories. I ran the new bad boy horn via a relay that uses the existing horn button to fire the power line to the horn.

    I discovered when I hit my horn it causes the cruise to cut out. I am guessing it is causing a power drop in the system since the cruise and the horn only share the battery. Would adding a small stereo capicitor (.5 farade) fix this, it makes sense that storing power for the horn would elimate the problem but what are you thoughts?
     
  2. WI_Hedgehog

    WI_Hedgehog Winner of the "Most Factory Defects" award Staff Member Moderator

    Joined:
    Apr 27, 2015
    Messages:
    2,679
    Thanks Received:
    1,393
    Trophy Points:
    353
    Location:
    Milwaukee, WI
    You should learn to drive like the rest of us. Fast. :cold:
     
    • Like Like x 1
  3. MRD

    MRD Well-Known Member

    Joined:
    Oct 3, 2016
    Messages:
    357
    Thanks Received:
    153
    Trophy Points:
    98
    Location:
    Lynden WA
    That is why I need the horn! lol
     
    • Winner Winner x 2
  4. WI_Hedgehog

    WI_Hedgehog Winner of the "Most Factory Defects" award Staff Member Moderator

    Joined:
    Apr 27, 2015
    Messages:
    2,679
    Thanks Received:
    1,393
    Trophy Points:
    353
    Location:
    Milwaukee, WI
    That's awesome! Seriously though, on an SL with stock stereo I came off the alternator with a 12ga wire to the supplied BadBoy relay tripped by the stock horn (which also fires off) and no problems. You shouldn't be seeing a problem either, unless your fat wire is allowing so much current on horn startup that the overly-sensitive Slinshot electronics panic, in which case you're currect a crapacitor (like Rockford Fosgate) would solve the issue.

    EDIT: UNLESS it's a noisy relay because the connectors are arcd out, then it's inducing noise into the system.
     
    Last edited: Apr 20, 2017
  5. MRD

    MRD Well-Known Member

    Joined:
    Oct 3, 2016
    Messages:
    357
    Thanks Received:
    153
    Trophy Points:
    98
    Location:
    Lynden WA
    Yes, that is what I was thinking, the high draw from the horn is causing the ss electronics issues, a capacitor would store power so no drop would be seen by the system.
     
    • Agree Agree x 1
  6. 2W2X1

    2W2X1 Well-Known Member

    Joined:
    May 20, 2016
    Messages:
    797
    Thanks Received:
    364
    Trophy Points:
    118
    Location:
    Bay Area, CA (South Bay)
    Wait the SS has cruise control? :rolleyes:



    BWAHAHHAHA I never use it.
     
    • Funny Funny x 2
  7. MRD

    MRD Well-Known Member

    Joined:
    Oct 3, 2016
    Messages:
    357
    Thanks Received:
    153
    Trophy Points:
    98
    Location:
    Lynden WA
    I use it all the time to avoid tickets, lol. I only run without cruise in heavy traffic. It is much more restful on a long trip and it helps me with better gas milage.
     
    • Agree Agree x 1
    • Funny Funny x 1
  8. TimC

    TimC Well-Known Member

    Joined:
    Jun 29, 2016
    Messages:
    354
    Thanks Received:
    165
    Trophy Points:
    198
    Location:
    NY
    I put on Badboy horn and connected it to stock wiring.. no issues
     
  9. MRD

    MRD Well-Known Member

    Joined:
    Oct 3, 2016
    Messages:
    357
    Thanks Received:
    153
    Trophy Points:
    98
    Location:
    Lynden WA
    I have a lot of accessories so I suspect that is route cause.
     
    • Informative Informative x 1
  10. WI_Hedgehog

    WI_Hedgehog Winner of the "Most Factory Defects" award Staff Member Moderator

    Joined:
    Apr 27, 2015
    Messages:
    2,679
    Thanks Received:
    1,393
    Trophy Points:
    353
    Location:
    Milwaukee, WI
    That could eventually burn out the horn compressor due to low voltage from undersized wires.
    The Slingshot alternator is near max already, if you're using gobs of current and starting up a small compressor... A flux capacitor should solve the problem.
     
  11. super

    super Well-Known Member

    Joined:
    Nov 11, 2014
    Messages:
    881
    Thanks Received:
    440
    Trophy Points:
    118
    Location:
    Beverly Hills CA
    What's a cruise control
     
    • Like Like x 1
  12. MRD

    MRD Well-Known Member

    Joined:
    Oct 3, 2016
    Messages:
    357
    Thanks Received:
    153
    Trophy Points:
    98
    Location:
    Lynden WA
    I am in the process of adding a capacitor, a bit bigger than I wanted but that won't hurt. It is charging up right now so I will have to report back later how it works.
     
    • Like Like x 1

Share This Page