Garmin Zumo 590 LM installation?

Discussion in 'Polaris Slingshot Electronics' started by Ian Gibbs, Jul 20, 2016.

Tags:
  1. Ian Gibbs

    Ian Gibbs Member

    Joined:
    Mar 29, 2015
    Messages:
    44
    Thanks Received:
    5
    Trophy Points:
    8
    Location:
    Minnesota
    Greetings folks,

    I've scanned this forum to find the answer, but I'm afraid I can't locate a good solution. Please forgive me if this has already been discussed and resolved.

    I've currently got a Garmin Zumo 660 connected in to the radio on my Slingshot SL using the mount/cord that Garmin made for one of the Victory motorcycles. (Found that neat tip here last year - thanks!)

    However, my 660 is showing its age. I'm contemplating getting a Zumo 590 instead. Has anyone found a plug-n-play mounting kit that works for this setup? I'm hoping that Garmin has, once again, made a mount to install this on that Victory motorcycle and it would work here too.

    I imagine it can be connected via Bluetooth, but something tells me that a hardwire connection would be better. (As I recall it, the SS radio only allows one bluetooth "accessory" and I'd like that to be my phone.)

    Many thanks in advance!

    Ian
     
  2. dqsling

    dqsling New Member

    Joined:
    Oct 19, 2016
    Messages:
    6
    Thanks Received:
    3
    Trophy Points:
    3
    Hey Ian - Just wanted to check in with you on this to see if you have found a solution. I purchased a Garmin 595 last week, along with the Garmin/Victory Part 2877930 to interface with the Slingshot radio. Unfortunately today, I when I opened the box I learned that not all Zumo connections are the same. The cradle that is part of Part 2877930 is only for a Garmin 660, and is too small for the 590 or 595 (which both use a larger cradle) I spoke to Garmin and the rep told me that this harness is manufactured by Victory and not Garmin. although uses Garmin parts. So I called Polaris and spoke to them for better part of half of hour. As you can imagine, I didn't get very far. They have no knowledge of any plans to make a new harness that will work with the newer Zumo's and interface to the SS. So, unless I can find another solution, I am left with either getting an old 660, or keeping the 595 with no way to interface it into the radio. Let me know if you have any updates. Thanks!
     
  3. Ian Gibbs

    Ian Gibbs Member

    Joined:
    Mar 29, 2015
    Messages:
    44
    Thanks Received:
    5
    Trophy Points:
    8
    Location:
    Minnesota
    Bummer for us both! I've not yet found a reasonable solution either. :( Quite keen to hear about anything you might find.
     
  4. dqsling

    dqsling New Member

    Joined:
    Oct 19, 2016
    Messages:
    6
    Thanks Received:
    3
    Trophy Points:
    3
    Hi Ian - I actually do have an update. I have things working, at about 90% of where I want to be. Through my continual searching on the forum, I found a document of plans posted, that worked for me. Joe Smith created two documents, and the one that he posted that deals with the Garmin 665, will work for the Garmin 595. I will try to send his attachment.

    I used the Garmin direct wire harness that was included with the Garmin 595. I took off the windscreen, and ran the wire down and back into the radio compartment. The wire fits under the windscreen snug, but not too tight. I ran the power cables over to a Secondary Fuse Block I installed previously. (Available from Slingmods.com). And then I created the pigtail audio connection to plug the Audio Out from the Garmin into the SS radio using the directions in the link above. I then ran the Garmin USB connection into my glovebox, running it along the firewall. Not sure I will be using it, but that interface allows the Garmin to effectively replace the slingshot radio interface for all the services I use (such as Pandora, or the music on my iphone, but it is simply a back up connection for me. Its there if I ever need it)

    The challenge I have had, is interference or feedback coming across the audio connection. I can have my iphone playing Pandora using the stock USB connection into the Slingshot radio. When the GPS begins to give me directions, it overrides the iphone audio and the Slingshot Radio will read "NAV Audio" on the screen. When the directions are done, the music begins playing again. Works great. But I am having one problem....

    Anytime I am over 50mph, my music keeps cutting out if the GPS is plugged into the dock. (Even if I turn it off, it still happens). If I remove the GPS and put into the glovebox, problem goes away. My current running theory is electrical interference in my audio cables. When I spliced my audio pigtail into the L, R, and G, I struggled with those three tiny wires and especially the ground, which is acting as the shield, as copper strands around the L and R channels. (Still not sure why it only happens when going over 50). So, I have ordered this part: Victory 2877196. It is very pricey for what it is, but I have ruined 4 audio cables trying to solder those tiny wires. So, I am going to cut off the built in harness in this part, and solder directly into the wires identified in the document via the link above. (Attached is a picture of the part I ordered). I will let you know if that solves my "above 50mph interference problem".




    Sent from my iPad using Tapatalk
     
  5. dqsling

    dqsling New Member

    Joined:
    Oct 19, 2016
    Messages:
    6
    Thanks Received:
    3
    Trophy Points:
    3

    Attached Files:

Share This Page